• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Kudos5

Firefox 28 Support for Norton Toolbar

Updated March 20, 2014 - Identity Safe Standalone updated to 2014.7.0.43

Hi Everyone,

We've done something different than in previous Firefox patches. When the Firefox 27 compatibility patch was released last month, it also contained compatibility for Firefox 28. This means that all the products that received the Firefox 27 compatibility patch already have Firefox 28 compatibility, as well as versions that have been released since that time.

 

Below are the list of versions for the products and the versions of Norton Toolbar that are compatible with Firefox 28:

Norton Internet Security, Norton 360 & Comcast Norton Security Suite

Version 21.1.0 - Norton Toolbar 2014.6.5.1

Version 21.1.1 - Norton Toolbar 2014.6.6.3

Version 21.2    - Norton Toolbar 2014.7.0.43

 

Norton Identity Safe Standalone: 

Norton Toolbar2014.7.0.43

 

 

Norton Internet Security & Norton 360 v20.4.0.40

 

Norton Toolbar2013.4.8.1

 

 

Norton Internet Security 2012 (19.9.1.14) & N360 2012 (6.4.1.14)

Norton Toolbar2012.5.22.3


We recommend that you have the latest version of Norton Internet Security or Norton 360 installed.  If you are not seeing the Norton Toolbar in Firefox 28, check and make sure you're running any of the above versions of NIS, N360 or NSS. Please visit our Norton Update Center to receive the latest update. 

 

You may need to run LiveUpdate and reboot a few times before your product is completely updated to the latest version. It will appear in the LiveUpdate history as Norton Toolbar Add-on for Firefox.

 

If you are running Firefox 28 and Norton Internet Security, Norton 360 21.1.0.18 or NSS 21.1.0.18and still do not see the Norton Toolbar, please ensure the Norton Toolbar plugin is enabled. You can do this by clicking on the Firefox menu, selecting Extensions, and then clicking Enable next to Norton Toolbar.

Please note: We now only officially support Firefox 25.0 and above. Firefox 24 and older are no longer supported. See this announcement for more information.