• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Kudos0

LiveUpdate pops up to ask for permission to run, and then fails with error codes LU 1812 and LU 1806

THE PROBLEM: After upgrading from NIS 2008 to NIS 2009, LiveUpdate began popping up in the lower-right corner of the screen every few hours, saying "Update Available".  Under previous versions of NIS, LU just ran silently and automatically, never asking for permission. Now, clicking "Yes" led to a LiveUpdate Express list of components, and clicking "Start" initiated the update downloads. When they finished, installation began, but always failed with an LU 1812 error (trying to install "LiveUpdate Notice") followed by an LU 1806 error.  A few hours later, the pop-up reappeared and the same things happened every time.

By contrast, clicking "Live Update" in the NIS window always worked.

Symantec Support's "Chat" technician bypassed the problem by turning off "Automatic LiveUpdate" in "Computer | Settings", but that didn't seem to be a good solution, since those updates are needed and I don't want to have to remember to do them manually.

THE CAUSE: There was a two-year old copy of the LiveUpdate components in C:\Program Files\Symantec\LiveUpdate", and it seems that its content ran instead of the current LU packaged with NIS 2009.  The old copy didn't understand the new NIS and/or couldn't find needed components to be updated.

THE SOLUTION: 1) rename that folder to something else (it probably could be deleted, but renaming is safer).  2) Install the current version of LiveUpdate and reboot.  (Installing it without renaming the original folder did not solve the problem.)  Thereafter, "Automatic LiveUpdate" can be turned ON, and it will work properly without any pop-up requests for permission to run LU.  You can install LU from here (the address in that link is: http://service1.symantec.com/Support/sharedtech.nsf/docid/1999051911110813)

Now, it's entirely possible that just renaming or deleting the old LiveUpdate folder, without installing the current LiveUpdate, would also work; but I didn't try that.

Replies

Kudos0

Re: LiveUpdate pops up to ask for permission to run, and then fails with error codes LU 1812 and LU 1806

THE PROBLEM: After upgrading from NIS 2008 to NIS 2009, LiveUpdate began popping up in the lower-right corner of the screen every few hours, saying "Update Available".  Under previous versions of NIS, LU just ran silently and automatically, never asking for permission. Now, clicking "Yes" led to a LiveUpdate Express list of components, and clicking "Start" initiated the update downloads. When they finished, installation began, but always failed with an LU 1812 error (trying to install "LiveUpdate Notice") followed by an LU 1806 error.  A few hours later, the pop-up reappeared and the same things happened every time.

By contrast, clicking "Live Update" in the NIS window always worked.

Symantec Support's "Chat" technician bypassed the problem by turning off "Automatic LiveUpdate" in "Computer | Settings", but that didn't seem to be a good solution, since those updates are needed and I don't want to have to remember to do them manually.

THE CAUSE: There was a two-year old copy of the LiveUpdate components in C:\Program Files\Symantec\LiveUpdate", and it seems that its content ran instead of the current LU packaged with NIS 2009.  The old copy didn't understand the new NIS and/or couldn't find needed components to be updated.

THE SOLUTION: 1) rename that folder to something else (it probably could be deleted, but renaming is safer).  2) Install the current version of LiveUpdate and reboot.  (Installing it without renaming the original folder did not solve the problem.)  Thereafter, "Automatic LiveUpdate" can be turned ON, and it will work properly without any pop-up requests for permission to run LU.  You can install LU from here (the address in that link is: http://service1.symantec.com/Support/sharedtech.nsf/docid/1999051911110813)

Now, it's entirely possible that just renaming or deleting the old LiveUpdate folder, without installing the current LiveUpdate, would also work; but I didn't try that.

Kudos0

Re: LiveUpdate pops up to ask for permission to run, and then fails with error codes LU 1812 and LU 1806

As suggested by dbrisendine, if you don't have older Norton products installed on your PC, you don't need to download LiveUpdate seperately. If you have problems, you should reinstall NIS, as you cannot reinstall LU seperately.
Kudos0

Re: LiveUpdate pops up to ask for permission to run, and then fails with error codes LU 1812 and LU 1806

When NIS was upgraded from NIS 2008 to NIS 2009, NSW 2006 and Ghost 10.0 had already been installed for years.  While trying to solve the LU pop-up problem, one the several things I tried was to uninstall both NSW and Ghost.  That did not solve the problem.  As my original post explained, renaming the Symantec\LiveUpdate folder and then installing LU from the website did solve it.  Based on the first two replies to the original post, it seems that just renaming the folder would have sufficed to solve the problem.  Thank you for the additional information.
Kudos0

Re: LiveUpdate pops up to ask for permission to run, and then fails with error codes LU 1812 and LU 1806

CharlieHoward -

Do you have any other Norton products installed other than NIS2009?

Edit:  For others reading this -

 All the current 2009 Norton AV products (NIS, NAV and N360) have a built in version of Live Update.  If installing one of these products and there are no other Norton products on the system, you can and should uninstall the stand alone Live Update application.

Message Edited by dbrisendine on 05-30-2009 07:14 PM
Win7 x32 SP1

Replies are locked for this thread.