• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Kudos0

Norton Ghost 15 - convincing network adapter driver to load

Hi

I'm running Norton Ghost 15 standard (with latest updates), I'm trying to create a boot disk, it seems however the network driver fails to load....

I'm adding this network driver which I know is correct (open the ZIP and you will see only 3 files or so, and just one NIC):
http://www.marvell.com/drivers/driverDisplay.do?driverId=206

It appears the INF file states multiple adapter types, however Norton Ghost only "detects" the first NIC in the INF file, consequently it fails to start network services with the wrong NIC.

I've tried editing the INF file to convince Ghost - does not work however - I suspect I'm not doing this correctly.


The correct NIC should be a "Marvell Yukon 88E8040 Family PCI-E Fast Ethernet Controller" which is listed in the INF file (see link above). Could anybody please help?


Thanks!

Alex

Replies

Kudos1

Re: Norton Ghost 15 - convincing network adapter driver to load

You want a Vista 32bit driver, not windows 7, Server 2008

Are there more drivers availible for that system?

Dave

Kudos0

Re: Norton Ghost 15 - convincing network adapter driver to load

It's a Windows 7 32 bit driver (which should work fine). The issue is it fails to get the correct network card in the INF file which contains details for multiple adapters. Ghost just looks at the first entry on the list (provided by the INF file). I can only assume the INF file needs to be edited somehow (see first post). Thanks...

Kudos1

Re: Norton Ghost 15 - convincing network adapter driver to load

That support site is messed up, all links download the windows 7 driver even if you choose vista or XP.

Try this one:

http://drivers.softpedia.com/progDownload/Marvell-Yukon-Gigabit-Ethernet-Adapter-Vista-Driver-91233whql-Download-20932.html

Be carefull you don't click the download buttons for any of the other junk.

You want to click where it says " Softpedia Mirror (US)" off to the right.

You should end up with a zip file called "marvell yukon 9.12.3.3-whql-vista32-64bits.exe".

Try the x86 driver inside, extract it to your hard drive or flash stick.

Then boot the recovery disk and manually load the driver as a test, then start the network service and see if it works.

If it does you can then build a custom recovery disk.

Dave

Kudos1

Re: Norton Ghost 15 - convincing network adapter driver to load


NAlexS wrote:

It's a Windows 7 32 bit driver (which should work fine). The issue is it fails to get the correct network card in the INF file which contains details for multiple adapters. Ghost just looks at the first entry on the list (provided by the INF file). I can only assume the INF file needs to be edited somehow (see first post). Thanks...


The Ghost recovery disk is built on Vista 32bit.  Regardless of what OS is installed on your system the recovery disk needs vista drivers.

Kudos0

Re: Norton Ghost 15 - convincing network adapter driver to load

Thanks Dave... I really do appreciate this...

I followed your instructions to the letter and Ghost incorrectly finds a
"SysKonnect Marvel RDK-8001"... Looking at the inf file (32 bit Vista) there is no 88E8040 adapter in the inf file.

Also tried this driver which does contain Vista drivers and correct INF entry, again Ghost detects the first adapter on the INF list (and therefore the wrong adapter):


http://www.marvell.com/drivers/driverDisplay.do?driverId=101


Not sure what to do now...

Thanks

Alex

Kudos0

Re: Norton Ghost 15 - convincing network adapter driver to load

Original issue also happens with these drivers I just got from Dell... It seems that Ghost is not parsing the correct info from the INF file, or at least giving me an adapter to select (just supplies the first adapter):

http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R167854&SystemID=XPS_M1530&servicetag=7CNT9F1&os=WLH&osl=en&deviceid=15608&devlib=0&typecnt=0&vercnt=1&catid=-1&impid=-1&formatcnt=1&libid=5&fileid=227515

Kudos1

Re: Norton Ghost 15 - convincing network adapter driver to load

Regardless of what it names the device, does it work?

Looking at all the sections below in the inf for different devices all the main parameters look the same to me.

Like you said, there is only one driver file to use.

I see the line in the .inf that must be loading (from your link)

%RDK-8001.DeviceDesc% = SLYukCopGig_2BA069C3.ndi, PCI\VEN_1148&DEV_4320&SUBSYS_01211148

If you look in the device manager while in windows, is that not the device string listed under "details"?

PCI\VEN_1148&DEV_4320&SUBSYS_01211148

After your loading the driver, wait a minute and then make sure your going to "Network" and clicking "load network services"

That can take a couple minutes.

Dave

Kudos0

Re: Norton Ghost 15 - convincing network adapter driver to load

Hi Dave

Nope not working I'm afraid:

Here are the HardwareID's:

PCI\VEN_11AB&DEV_4354&SUBSYS_C070144D&REV_00
PCI\VEN_11AB&DEV_4354&SUBSYS_C070144D
PCI\VEN_11AB&DEV_4354&CC_020000
PCI\VEN_11AB&DEV_4354&CC_0200


Cheers!

Accepted Solution
Kudos1

Re: Norton Ghost 15 - convincing network adapter driver to load

Thats strange, none of those drivers have the correct hardware ID string.

I found an older version that does, but it's not a self extracting file and the only tool I could find to open it is 7zip.

There is a half dozen or so inf files inside and I found one thats is for vista and has the right ID.

it uses version 11.24.3.3 of the yk60x86.sys file.

It may be easier if I just take those files and upload them somewhere.

Give me a minute and I'll send you a provate message, click the envelope icon near the top of the screen.

Dave

Kudos0

Re: Norton Ghost 15 - convincing network adapter driver to load

Hi Dave

It detected the wrong adapter... I tried it anyway.....

IT WORKED!

Weird eh?

Thankyou so much... finally nailed my backup strategy,.... not a moment too soon it seems as I live in London :)

Cheers and thankyou again!

Alex