• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Kudos0

Cannot access localhost, 127.0.0.1

Is it possible to password protect the localhost?

For several weeks now I have not been able to access the localhost on 2 different PC's. Both are running Norton Internet Security 2012.

From Chrome I'm getting an authentication request: "The Server 127.0.0.1:80 requires a username and password"

Firefox and IE give me a similar messages, but don't indicate the port. 

A brief history: I'm running XP on two different PC's; a laptop and a desktop. Up until a couple of weeks ago I didn't have any problems. I'm trying to learn PHP. I was running the Apache server without any problems (I know about IIS and Apache both needing port 80 - I solved that problem and everything was working). I stopped working on PHP to reacquaint myself with HTML and CSS for a couple of weeks. When I went back to PHP my programs wouldn't run. And I could no longer access localhost.

I get the logon requirement whether I'm connected to my router or not, whether IIS or Apache are running or not. I have no trouble accessing the internet. I changed the port IIS was listening to to 40, but the problem persists. I really don't think it has anything to do with my local web server software, you don't need it to run a browser or access localhost, right?.

I can ping 127.0.0.1 and I can ping my router 192.168.1.1. I've powered the router on and off several times. I've even reset it to the factory defaults, but my problem persists.

The only thing that has been installed on both computers during the time frame in question were updates from Norton and Microsoft. So, the problem seems to come from a Norton update, a Microsoft update, or me. If it was a Norton or Microsoft update I'm fairly certain I wouldn't be the only one suffering. That leaves who?

I am wide open for suggestions.What did I do?  I'm the only one on the PC's and router, and I have admin access to both. 

Thanks,

David Morris

P.S. I can't reinstall windows, I lost the product key.

Replies

Kudos0

Re: Cannot access localhost, 127.0.0.1

Is it possible to password protect the localhost?

For several weeks now I have not been able to access the localhost on 2 different PC's. Both are running Norton Internet Security 2012.

From Chrome I'm getting an authentication request: "The Server 127.0.0.1:80 requires a username and password"

Firefox and IE give me a similar messages, but don't indicate the port. 

A brief history: I'm running XP on two different PC's; a laptop and a desktop. Up until a couple of weeks ago I didn't have any problems. I'm trying to learn PHP. I was running the Apache server without any problems (I know about IIS and Apache both needing port 80 - I solved that problem and everything was working). I stopped working on PHP to reacquaint myself with HTML and CSS for a couple of weeks. When I went back to PHP my programs wouldn't run. And I could no longer access localhost.

I get the logon requirement whether I'm connected to my router or not, whether IIS or Apache are running or not. I have no trouble accessing the internet. I changed the port IIS was listening to to 40, but the problem persists. I really don't think it has anything to do with my local web server software, you don't need it to run a browser or access localhost, right?.

I can ping 127.0.0.1 and I can ping my router 192.168.1.1. I've powered the router on and off several times. I've even reset it to the factory defaults, but my problem persists.

The only thing that has been installed on both computers during the time frame in question were updates from Norton and Microsoft. So, the problem seems to come from a Norton update, a Microsoft update, or me. If it was a Norton or Microsoft update I'm fairly certain I wouldn't be the only one suffering. That leaves who?

I am wide open for suggestions.What did I do?  I'm the only one on the PC's and router, and I have admin access to both. 

Thanks,

David Morris

P.S. I can't reinstall windows, I lost the product key.

Kudos0

Re: Cannot access localhost, 127.0.0.1

Your router does not come into play with localhost, as it is what the name implies, so don't bother with the router for a solution. I assume you are running Apache and IIS on different ports? I know you mention moving the IIS port, just want to be sure they aren't listening on the same port at the same time. The first thing I would do is temporarily disable the firewall, and see if that solves the problem. If it does then work on firewall exceptions. If not then you are having a problem with IIS/Apache and/or PHP. Also, there are programs that can retrieve your Windows product key if you have lost it.

Replies are locked for this thread.