Not what you were looking for? Ask our experts!
Reply
Tony_Weiss
Posts: 8,028
Topics: 572
Kudos: 2,043
Solutions: 321
Registered: ‎04-07-2008

Attention: Firefox 3 through 28 users

[ Edited ]

In order to ensure high quality and timely Firefox compatibility updates, we have removed support for older versions of Firefox.

 

As of this posting, we will only support Firefox 29 and above. Beta and Pre-Release versions of Firefox will not be supported until they are released. If you are running Firefox 3.x through Firefox 28.x, it is highly recommended that you upgrade to a more recent version of Firefox at:

 

http://www.firefox.com

 

As the number of older versions of Firefox increases, the time it takes to develop and test against all older versions (along with the new version of Firefox) increases and can cause delays in releasing the update. To ensure that we can release timely compatibility updates for newer Firefox versions, we have removed support for the older versions of Firefox.

 

It is important to keep Firefox updated so that you can continue to use the Norton Toolbar and Intrusion Prevention. You should also keep Firefox up-to-date so you can benefit from all the security updates that Mozilla includes in each new release.

 

Please let us know if you have any questions or concerns.

 

[Edit: updated July 22  2014 to reflect current compatibility of Firefox 29 and newer]

Tony Weiss
Norton Forums Global Community Manager
Symantec Corporation