Android Studio Dev - losing internet connection due to com.symantec.mes.systemextension

As a Flutter Developer, I use Android Studio with Android Emulators and iOS Simulators running on my work MacBook. I've been developing with this particular environment since July 2021. In that time, I've had a nearly daily issues with my MacBook randomly losing the internet connection once I open an Android Emulator then deploy my Flutter app. You might get half a day without problems, other days it goes wrong the first time you do anything at the start of the day.

When this problem occurs, the macOS Network Settings panel will show both the WiFi and Ethernet/LAN connection as 'Connected' to the internet. However, no web browsers (Safari, Chrome, Edge) can load or refresh any webpage - they'll just report there is no internet connect. Similarly, any other application that requires the internet will fail to connect.

Early on I realised the issue was related to Norton 360. When this is happening, if you look at the the macOS Activity Monitor it shows "com.symantec.mes.systemextension" near (or at) the top of the CPU usage list, and the MacBook fans are usually making a lot of noise at that time (on full blast). General responsiveness of the OS is pretty poor at this point, aside from having no internet connection.

As a workaround, I found that going into the Firewall settings and disabling all options could prevent (or at least reduce) the likelihood of this issue happening. I also found it important to turn all that off before even starting Android Studio itself, else you could get an issue where after then opening an Android Emulator, the IDE would not connect to it and complain about some 'daemon' related error (the socket/port it talks to the emulator over is blocked).

I had also tried adding Scan folder exceptions to ignore any of my Android Studio installation folders, SDK folders (Flutter SDK, Java SDK etc) and my development project folders. And I also tried adding Connection Blocking exceptions to allow the Android Emulator process ‘qemu-system-x86_64’  to not be hindered etc. None of that helped at all.

So, once I figured all that out, I'd basically start my working day by turning off all Norton Firewall options and Scan options. A bit pointless having Norton 360 installed at all by this point really...

However, with all of that disabled, I would still get the same issue occur at some point in the day. This would totally nuke my productivity. Sometimes Force Quitting all Android emulators could fix it. Other times I would have to clean my entire Android Studio project manually (delete all temp/cache folders such as: /build, /.gradle, /.symlinks, /Pods, run 'flutter clean' etc). If that didn't work I'd have to restart the MacBook. 

It has been a pretty stressful & aggravating experience!

Today, though I normally only get the issue on Android Emulators, I started getting a similar issue on iOS Simulators when building and deploying a Flutter app.

Using Activity Monitor, applying a Force Quit to "com.symantec.mes.systemextension" would temporarily restore the internet connection to the MacBook and emulators/simulators running the Flutter app. However, after a short period of time (less than a minutes sometimes) it would all break again.

I happened to have a look at the Norton Community for Mac pages today. Though I'm not using it myself, people upgrading to Ventura are clearly having severe issues and quite a few posts mention "com.symantec.mes.systemextension" and/or loss of internet connection generally.

I think that put the nail in the coffin for me. I'm so fed up with Norton 360 causing various Mac issues. I can't even be bothered to mention all the other random stuff or Kernel Panic issues Norton has caused since I moved to Mac based development back in 2019.

This evening I've uninstalled Norton 360 from my work MacBook and used the RemoveNortonMacFiles tool. The tool seems to be required to fully get rid of "com.symantec.mes.systemextension".


I won't be installing it again on a Mac. This product is too poorly developed and tested to be suitable for end users.

It's a shame as I use Norton 360 on my Windows PC's & laptops and normally don't get any issues at all. On Mac it is absolutely awful, crippling performance and taking 10 times longer to scan an in internal SSD than a similar Windows laptop takes...

I'll now have to find some other free Mac Antivirus software, or buy a license for something decent. This is very annoying as I already pay a lot for a yearly subscription to Norton 360 Premium to get 10 licenses to cover our PC's and Macs.

My recommendation is for Mac users to find some other Antivirus & Firewall Security package.

For reference, my system specifications:

  • MacBook Pro (16-inch, 2019)
  • 2.6 GHz 6-Core Intel Core i7
  • 32 GB 2667 MHz DDR4
  • 512 GB SSD
  • AMD Radeon Pro 5300M 4 GB
  • macOS Monterey, v12.6.1
  • Norton 360 v8.8.1 (before uninstall).

History of macOS and Android Studio combinations I have experienced this with on the same MacBook:

  • macOS: Catalina, Big Sur, Monterey
  • Android Studio: pre Artic Fox (?) Artic Fox, Bumblebee, Chipmunk, Dolphin