• Gesamte Community
    • Gesamte Community
    • Foren
    • Ideen
    • Blogs
Erweitert

Nicht was Sie suchen? Die Experten fragen!

Danksagungen0

ccSvcHst.exe, Nvidia Optimus using GPU

Hello community,

When I upgraded to the newest version of Norton 360, I noticed that my GPU in my laptop comes on when I'm hooked to an external monitor, which is normal. However, if I unplug my laptop, the GPU remains on because "ccSvcHst.exe" is apparently using the GPU still instead of the integrated graphics. Does anyone else have this issue? Is there a fix? I've already set the .exe to only use Integrated Graphics via the Nvidia Control Panel.

Thanks!

Antworten

Danksagungen0

Re: ccSvcHst.exe, Nvidia Optimus using GPU

This is interesting. I wish I understood more because I thought that if you have a GPU/VPU in a laptop that it would be used all the time and that it was ipso facto the integrated graphics. Also I dont understand which exe or how you set it not to use GPU.

SOrry I cant help but I will follow this with interest.

.
Danksagungen0

Re: ccSvcHst.exe, Nvidia Optimus using GPU

Thanks for the reply and interest though!

Yes, I'm not sure how new the technology is, but I purchased this Dell L502x laptop last year before I went off to school. It came with this technology where it will shut the GPU off automatically when it is not in required to be used, and will use the built in graphics controller on the mainboard (i.e. Intel's HD graphics). When you go into the Control Panel for Nvidia, you can force which programs use the GPU (or in this case, do not). I added the .exe to the list, and selected for it to use the Integrated graphics only. Doesn't seem to work when I boot my laptop with an external monitor hooked up, though.

I would consider the graphics driver being part of the culprit, but I didn't have this issue with the previous version of 360. I just upgraded a few days ago, and that's when this problem started.

Danksagungen0

Re: ccSvcHst.exe, Nvidia Optimus using GPU

*bump* Any ideas anyone??

Danksagungen0

Re: ccSvcHst.exe, Nvidia Optimus using GPU

It looks like it occurs only when I boot my laptop while it's connected to the external monitor.

Danksagungen0

Re: ccSvcHst.exe, Nvidia Optimus using GPU

Update: Looks like when I open Norton, then close it, Norton no longer uses the GPU. Strange. May be something to do with the graphics driver.

Danksagungen1 Stats

Re: ccSvcHst.exe, Nvidia Optimus using GPU

I'm also experiencing this problem. I have a Lenovo ThinkPad T530, which I just bought a couple months ago, and it has the same nVidia Optimus technology that yours has (runs a program using the discrete GPU if the laptop is connected to power). I also specified in the nVidia Control Panel for ccSvcHst.exe to always run with Integrated Graphics instead of the GPU, but this doesn't actually seem to happen.

It seems to me like the problem is that during system boot, Norton recognizes that the laptop is connected to power and starts the service on the GPU. But since ccSvcHst.exe runs constantly (and can't be killed in Task Manager) it continues on the GPU for the rest of the session, even if I disconnect from power later. It seems like there ought to be an option in Norton to set whether it utilizes the GPU or not.

The main problem is that because of this, the battery lasts almost half as long when booted on external power (4.5hrs non-cpu intensive tasks), vs. booted on battery (8-9hrs non-cpu intensive). And I rarely reboot away from my docking station.

Hopefully two people with the same problem will attract more attention than one.

Danksagungen1 Stats

Re: ccSvcHst.exe, Nvidia Optimus using GPU

Actually I just downloaded Process Explorer, and it shows that ccSvcHst.exe (with a pretty Norton icon) started a child process by the same name (without a pretty icon). Process Explorer can't find executable information about the process, such as where the executable file is located. Maybe this sub-process is part of the problem? I specified in the nVidia Control Panel for the "pretty icon" ccSvcHst.exe to use integrated graphics, but not necessarily the "default icon" child process ccSvcHst.exe. I'm wondering, maybe the sub-process is not loaded from an executable file but created on the fly by the parent process, therefore bypassing Optimus... or I'm just conjecturing beyond my knowledge :P

Although, Process Explorer doesn't show GPU usage by either of these processes, even while scanning or fiddling with the fancy Norton control panel, so I'm stumped again... (why would ccSvcHst activate the GPU if it doesn't even use it...?)

This thread is closed from further comment. Please visit the forum to start a new thread.