• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced
Kudos4 Stats

Firefox 32 Support for Norton Toolbar

[Update: The patch for Norton 2012 is now available]

Hi Everyone,

We have released a Firefox 32 compatibility patch for Norton Internet Security 21.5, Norton 360 21.5 and Comcast Norton Security Suite 21.5 which is available via LiveUpdate. The patch is also available for the Norton 2013, Norton 2012 and Norton Identity Safe standalone products.

The versions for this compatibility update are as follows:

Norton Internet Security, Norton 360 & Comcast Norton Security Suite  21.5.0.19

  

Norton Toolbar: 2014.7.7.13

 

 Note: For the 21.x update, this patch does not require reboot on Win7 & Win 8 machines.

Norton Identity Safe Standalone: 

Norton Toolbar2014.7.7.13

Note: For Identity Safe Standalone, this patch requires a reboot.

Norton Internet Security & Norton 360 v20.5.0.28

Norton Toolbar2013.4.13.10

Note: For the 20.x update, this patch does not require reboot on Win7 & Win 8 machines. 

Norton Internet Security 19.9.1.14 & N360 6.4.1.14

Norton Toolbar: 2012.5.27.1

Note: For Norton 2012, this patch requires a reboot.

Fixes:

Fixed the Safe Web Annotations issue for both Firefox 31 & Firefox 32 - See thread


We recommend that you have the latest version of Norton Internet Security or Norton 360 installed.  If you are not seeing the Norton Toolbar in Firefox 32, check and make sure you're running NIS, N360 or NSS 21.5.0.19. Please visit our Norton Update Center to receive the latest update. 

You may need to run LiveUpdate and reboot a few times before your product is completely updated to the latest version. It will appear in the LiveUpdate history as Norton Toolbar Add-on for Firefox.

 

If you are running Firefox 32 and Norton Internet Security, Norton 360 21.5.0.19 and still do not see the Norton Toolbar, please ensure the Norton Toolbar plugin is enabled. You can do this by clicking on the Firefox menu, selecting Add-ons, and then clicking Enable next to Norton Toolbar.

Please note: We now only officially support Firefox 30.0 and above. Firefox 29 and older are no longer supported. See this announcement for more information.