• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

NIS scans when not idle

I was using my machine when I noticed that something was hitting one of my disks VERY hard, and I was certainly NOT idle at that time.
I soon figured out that it was nortonsecurity.exe doing a scan, and not a brief one.
How can I stop NIS from doing a non-planned scan, even when I'm not idle?


Windows 10, NIS 22.15.1.8

Replies

Kudos1 Stats

Re: NIS scans when not idle

Quick scans should only run when idle unless your machine hasn't been allowed to reach an idle state for several days.  In that case it will run one eventually whether idle or not.

You can schedule Full System Scans to only run when idle.

Click the Security tile > Scans > Custom Scan > Go > on Full System Scan > Edit Scan > check Only at idle time > Next > Save.

A little bit of knowledge is... well a little bit of knowledge.
Kudos0

Re: NIS scans when not idle

Thank You for replying.

The scan in question must have been a quick scan and not a full scan, since it only took minutes and not hours. If it wasn't some other type of scan then ?

The configuration/schedule for a quick scan in the settings you describe was as I've set them, to run at night, 4am/04:00, and it ran this night the way it should. I'm still puzzled as to why NIS would hit my disk so hard when the machine was in use.

Any suggestions are welcomed.

Kudos1 Stats

Re: NIS scans when not idle

Hi reben:

What is the make/model of your computer, what are the basic system specs, and what is the version and build of your Win 10 OS (see https://www.howtogeek.com/236195/how-to-find-out-which-build-and-version-of-windows-10-you-have/)?  I don't know if it's a coincidence but I've seen a few recent threads about users with Intel i7 CPUs and/or SSDs (solid state drives) reporting unusually high CPU consumption by nortonsecurity.exe.  Do you have any other security software that loads a boot-up and runs in real-time protection mode (e.g., the paid version of Malwarebytes Premium) that might be conflicting with Norton?

It shouldn't be necessary to schedule a Quick Scan to run daily at 4:00 AM, since Quick Scan will automatically run during system idles after any Automatic LiveUpdate delivers a updated SDS (virus) definition set.  That being said, is it possible that your system is in sleep/hibernation mode at 4:00 AM and isn't waking up your computer to run your scheduled Quick Scan, causing the scan to be deferred until you eventually bring your system out of sleep/hibernation?

If you haven't already done so, disable the Fast Startup power option discussed in peterweb's thread Windows 8/8.1 or 10 and Fast Start Feature and then re-boot your system a few times after that setting is disabled.  This Fast Startup feature can interfere with product updates and loading of Norton services at boot-up and result in all sorts of odd glitches and unexpected behaviour on Win 8.x and Win 10 computers.

Please see C_Swords' thread My CPU is being abused by Norton for hints on how to use the  Norton Background Tasks window (Settings | Administrative Settings | Background Tasks | Configure) and Norton's Performance Graph (Performance | Graphs | Usage | CPU tab) to help diagnose what is causing your high CPU consumption.  You might be able to associate activity by nortonsecurity.exe (yellow peaks in the performance graph) with a Norton task like a Disk Optimizer disk defrag - a status of Canceled means you brought your system out of idle and temporarily paused a background idletime task. It's also possible that a Microsoft/Windows program or third party software (blue peaks in the performance graph) is triggering Norton's real-time Auto-Protect to "wake up" and monitor the behaviour of an executable.  See my comments in C_Swords' thread about how several Win 10 users found that disabling Native Image Generator (NGEN) tasks scheduled in the Windows Task Scheduler by the MS .NET Framework stopped the high CPU consumption by nortonsecurity.exe, as well as ithacacian's recent thread Idle Time Error in Norton Security 22.15.1.8 about high nortonsecurity.exe activity that seems to be associated with the Dashboard.exe process of their Seagate backup software.

Some Norton background tasks can't be disabled (e.g., like the Quick Scans that run during system idles every time your SDS virus definition set is updated) but there are several Norton tasks like the Idle Time Optimizer (disk defragmenter) that can be safely disabled without compromising your Norton protection.  See my 14-May-2018 post in C_Swords' thread My CPU is Being Abused by Norton for a list of settings that can be disabled to reduce your CPU consumption by nortonsecurity.exe.

-----------
32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * NS v22.15.1.8 * MB Free v3.5.1-1.0.365

Kudos0

Re: NIS scans when not idle

Thank you for replying. I need to quote many of your comments so you see where the replies apply. (Not that I mind many details.)

(Also, I hope that you're not running Vista Home Premium... - well, not easily connected to the internet at least...)

*"System": Built on ASUS - Maximus VI Formula, CPU Intel Core i7-4770S, 32GB RAM, 22TB HDs (That's why I could know it was a 'quick' scan..), and yes, it's got an SSD for the OS(es)(multiple). Windows 10 is Home, current, 1803, build 17134.345.

*"..conflicting with Norton": only Windows Defender, which 'pretends to be disabled' by the presence of NIS, by not allowing to be configured and such, but is active and shows itself from time to time, but I guess this is how MS/Windows wants it to be.

*"..system idles": is behaving quite well. I see this a lot even when 'I'm working' (but being idle, which, of course, may say something about my work..) Performance tasks like forking off disk defragger works just fine from NIS.

*"..Sleep/Hibernation..": No, this is not the issue. I could not only see that NIS ran the scheduled quick scan last night, but also have a backup replicator task run at 3am, which also ran just fine. So, no, sleep/hibernate shouldn't be in this picture.

*"Fast Startup": First I was unsecure if you meant BIOS Fast Startup or Windows. I see from the articles pointed to that it was the Windows one. YES, I do have Fast Startup enabled and would not like to have to turn it off. THIS MAY WELL be the cause for my experienced problem, but if this causes NIS to bug then I'd rather live with it and suffer those scans than turn it off - at least for the time being. I understand that this 'half-way' hibernation may cause issues. Many/most users uses this so if this is an issue with NIS it should be handled by NIS.

*"CPU": If you don't mind I'll skip commenting further on the CPU issue, since I found out that it was nortonsecurity.exe that was thrashing one of my disks (not all are in a RAID). The issue/bottlenecking here was the disk, not the CPU.

*"Norton background tasks..": As commented above, the handling at idling seems to be working well. No need to turn off the Idle Time Optimizer since it does not seem to be an issue here.

Kudos0

Re: NIS scans when not idle

As Krusty13 stated, Quick Scans will run during non-idle time if they have not had a chance to run during an idle period over the course of a few days.  This typically happens if you have set the Idle Time Out in Norton Settings at a high value that exceeds the amount of time that the computer is normally idle.  Try setting this to 1 minute so that the Quick Scan can start (and usually complete) as soon as the computer is idle.

Kudos1 Stats

Re: NIS scans when not idle

*"Fast Startup": First I was unsecure if you meant BIOS Fast Startup or Windows. I see from the articles pointed to that it was the Windows one. YES, I do have Fast Startup enabled and would not like to have to turn it off. THIS MAY WELL be the cause for my experienced problem, but if this causes NIS to bug then I'd rather live with it and suffer those scans than turn it off - at least for the time being. I understand that this 'half-way' hibernation may cause issues. Many/most users uses this so if this is an issue with NIS it should be handled by NIS.

The suggestion to turn off Fast Startup has to do with getting any program, not just Norton, that needs to update running system files the opportunity to complete the update. If you still wish to keep Fast Startup enabled, just be sure you at least do a system Restart once in a while. That will allow a full/complete shutdown of the Windows system and allow software updates to be fully processed.

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: NIS scans when not idle

SendOfJive: I do not think Quick Scans not being able to run can be an issue - the machine is on at all times and not sleeping nor hibernated. I sleep at night (day?) so there should be ample time to do 'housekeeping' for NIS. The log reports scans run at night as scheduled.

BUT ! - I did not know about the idle time out setting - where can I access this setting ?

Kudos0

Re: NIS scans when not idle

peterweb: That is good advice, but should I as a 'user' have to do a full shutdown/reboot? Shouldn't programs that need this for proper update either initiate this or at least prompt the user to do this? The latter will for sure confuse most users as they are not aware of the semi-hibernate functionality in place..

Kudos0

Re: NIS scans when not idle

I am not a programmer, but I do know there are command line commands that will do a complete shutdown of your system. Not sure if MS has done anything to mess this up within the Fast Startup code. But Norton is not the only software that gets affected when Fast Startup is involved.

And it has always been a best practice with Windows machines to do a full system restart every once in a while, to clear the cob webs. 

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: NIS scans when not idle

reben:

I did not know about the idle time out setting - where can I access this setting ?

It is in the Norton Administrative Settings.

Kudos0

Re: NIS scans when not idle

peterweb: >shutdown /r

will give you a full shutdown. You may want some more parameters, like timeouts and such, you'll get all the switches by doing a >shutdown /? command. <Shift> Shutdown in the GUI may work too.

Kudos0

Re: NIS scans when not idle

SendOfJive: " It is in the Norton Administrative Settings. " - Thank You.

Kudos0

Re: NIS scans when not idle

I do not think I have enough reproducibility for this problem to report it as a bug, so I'll just wait and see how it goes. Thanks for the suggestions.

This thread is closed from further comment. Please visit the forum to start a new thread.