• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos1 Stats

Norton Internet Security install fails on Kernel Extension permissions

I am having trouble installing today's version of Norton Internet Security on a Mac Mini ( late 2014) with a newly upgraded version today of Mac OS Catalina ( 10.15.1).    It is failing on asking me to give permissions for a Kernel Extension, but giving me no choice of Symantec ( or anything) in the permissions window.  I see other Mac users have run into this problem!

What's frustrating is that it seemed to work and I even ran Quick Scan,  but  then it's decided not to work any more. I see it described in a recent post on Catalina and temperature problems on this forum which I can't look up right now because I'd lose my place and it took me about 20 tries to get the "make new post" button to show up at all,  ( when I selected to make a new post from the link at the bottom of the search, it took me to my profile instead. Agghhh!! )

History of how I got to this state follows.

It is possible that many prior versions have not been fully removed from the Mac by the symantec removal tool 5.53 that I found on the mac (it's not my mac)

If all else fails I will just drag everything I can that says Norton in the trash and start with a new download, but as a heavy Windows user that action seems dangerous and risks leaving pieces around that I didn't see, so I have not tried that yet.  Maybe there is a new, better, fancy removal tool ( almost certainly ) and maybe I should get that.  We shall see.

In any case, I ran that removal tool when the download complained about a prior version existing.  It seemed to work, in fact I got normal operational screens and selected Quickscan and that worked, then I selected FULL SCAN, but after 20 minutes with a flashing progress bar and zero files scanned I tried Pause and Cancel, neither of which worked so I closed the window and rebooted the machine.   I guess that was a mistake, although I think it was already doomed at this point.

Anyway, now if I click on Norton it complains that it needs to be rebooted, and when i do that it comes up and wants to do an installation and when I select that choice, it dies when trying to make a Kernel Extension, which it apparently does not have permission for, but it also doesn't provide it's name in the right place for me to GIVE it such a permission.  

note -- i understand how the permissions work.  Earlier in the installation there were TWO symantec permissions it wanted and i unlocked the right little lock and selected to authorize other apps and picked symantec and it worked, or seemed to.

So i'm stuck. Probably in an unrecoverable state, or certainly in a state unfamilar to developers. 

Maybe my question is really, how can i clean off everything that norton owns and try again from downloading onward?  But if there's an easier way to save a few hours and fix what i have i'd love to hear it.

screenshots are on the mac and I'm posting from a different computer so they are not attached.  This is just the very normal screen used to give permissions to new developers to access the Mac, so not much info on them. It worked an hour ago.

Replies

Kudos0

Re: Norton Internet Security install fails on Kernel Extension permissions

The problem is solved in that i remove all traces of Norton products from my Mac using

Remove Symantec Software for Mac OS using RemoveSymantecMacFiles

http://www.symantec.com/docs/TECH103489

Then I manually went in and found any remaining files mentioning Symantec and deleted those too. After that a new download and install SEEMED to work.    It ran to completion.  I could use it to do a Quick Scan, which I did, and a Full Scan, which found 16 problems which were deleted or quarantined.  Then I rebooted and went to Norton and tried to do CLEAN.   There were maybe16 GIG of problem files.  I went to look at them in Norton and norton filled up memory and hung.  I had to reboot the machine. But now everything seems to be running very slowly, even browsers.   When I look in the Activity Monitor, com.symantec.mes.systemextension is the culprit, it is using 100% of a cpu and has burned 38 minutes of cpu time doing, as near as I can tell, nothing. 

I asked Symantec support if I could kill this process, but they told me that, no, that's just how Norton is, it uses up lots of RAM and CPU.  Wow. I had no idea.  

Now that I have spent about 10 hours total trying to get Norton to run, and look at how it runs, I think maybe i will simply delete the product entirely and  use something else instead.  Oh well. Live and learn

Kudos0

Re: Norton Internet Security install fails on Kernel Extension permissions

    I experience the same problem. In fact I have asked for support twice and they helped me to grant full disk access to all norton related extensions, namely 2x "com.symantec.SymlUHelper"s, "Norton System Extension" and "Norton". Also, accessibility is given to "AEServer" and "bash", and "Bash" is allowed to record my screen. Furthermore, firewall is turned on. However, the error message still pops up after a few restarts.

Kudos0

Re: Norton Internet Security install fails on Kernel Extension permissions

Here is a fast list of users reporting what sounds like the same problem with "Kernel Extension Permissions", with some of them, like me, also abandoning Norton entirely over this issue.

Me on 26-Nov-2019 

Norton Internet Security install fails on Kernel Extension permissions

Re: Norton Security Premium, Mac OSX 10.15 and fan overclocking

Re: Norton 360 doesn't work with Catalina (macOS 10.15)

Norton 9.0.1 and Catalina 10.15.1

Norton Security Premium, Mac OSX 10.15 and fan overclocking

Kudos0

Re: Norton Internet Security install fails on Kernel Extension permissions

Good grief. I had exactly the same issue. Am on MacBook Pro mid 2015. Running the new OS Catalina. And had Norton Internet Security. Spent a few hours with the support person online - gave all kinds of access, and it still kept falling over. Removed, reinstalled it, same crap. He finally said I need to upgrade as the version I have doesnt work this OS !! I have an annual subscription with auto renewal. Couldn't do anything else. So I did and went and got Norton 360 - guess what. Same crap is happening.  Wake up Norton your MAC software just isn't compatible with Catalina at 32 bit.. Please fix this. 

Kudos0

Re: Norton Internet Security install fails on Kernel Extension permissions

I'm in the same boat, Norton is not working with Catalina. I can't even contact any support from Norton... can't find a phone number and trying to chat just never opens up any chat window. (I'm in Canada, but that should not matter). I consider looking for a different security provider and request a refund from Norton, I just renewed in October. It is not just the problems with this issue which is upsetting enough but to have Norton not responding to any of this for two days is annoying! A payed security service like Norton should have costumer service when problems show up. This situation gives the impression that Norton is not up to the task to protect me from cyber threats and is not available when you need help. Norton talk to us!!!

Writing again on the same comment 25 minutes later.... Norton seems to be working, the new installation was suddenly able to be installed on my MacBook OS Catalina 10.15.1. I hope the issue is solved. Thank you