This forum thread needs a solution.
Kudos0

Blocking an app.

I wish to install the Ring app on my desktop.

It seems to install ok but will not run.

I have installed the app on 2 laptops with no difficulty but they are not running Norton 360 but using Windows 10 built in AV and Firewall.

I have tried disabling both the AV and Firewall on the desktop with no effect.

I had to uninstall Norton on one laptop to allow Ring to run but am reluctant to do the same on my desktop. My Norton 360 still has over 300 days to run, so would rather keep using it. Can I uninstall 360 temporarily?

Replies

Kudos0

Re: Blocking an app.

Have you tried contacting Ring Support to see if they have any suggestions?

If you disabled Firewall and Auto Protect, I'm not sure what could be blocking the app? Open your Norton to the classic interface and double click on the Security pillar. Then click on History. Look through the entries to see if you can find anything related to the Ring app. Let us know if you find something and it may help us figure out what is happening.

Things happen. Export/Backup your Norton Password Manager data.
Kudos1 Stats

Re: Blocking an app.

In addition to Peterweb's recommendations, a couple of other things you might check is if the RING App show under the firewall program control and if not, try adding it to the list.

If it still does not work, try adding the door bell device to the trusted devices either by its IP or its MAC address.

Could not find anything specific to Windows OS, but its mobile app seems to have a lengthy list of compatibility issues with most security apps to include Norton. Ref the following link  -  https://support.ring.com/hc/en-us/articles/115005889983-Android-Apps-tha...