• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Running Leopard, Firefox 3.5.2, Norton Confidential toolbar shows AMBER color w/message Error encountered. I have run LiveUpdate several times, restarted application, restarted computer. What gives? No where is there a list of error messages (in the app or online). I am trying so hard to resolve this.

BTW, same application in Safari 4 yields no problems. "No fraud detected" and "Monitoring" occur in solid black bar. Seems to be running properly.

Solution????? Any other info needed?

Replies

Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Usually this error is displayed when your Norton Confidential toolbar version is out of date, but you already noted that you have version 1.2.2f25 of Norton Confidential toolbar.

Are there any errors reported in the Console? To test, open the Console application (which can be found in Applications -> Utilities) and then select "system.log" in the left hand side of the Console window. Then launch the Firefox application, and see if you notice any new output in the system.log window of Console. Paste anything relevant here.

If you don't see anything interesting in Console, you can also make sure Norton Confidential's toolbar is capable of loading into Firefox. This will require some work, so if you aren't comfortable with it, let me know and I'll try and write a script to simplify it.

  1. In the Finder, open the Terminal application (Applications -> Utilities)
  2. Copy and paste the following into the Terminal window (without the colon):
     ls /Library/Application\ Support/Symantec/WebFraud/WCIDEngine.bundle/Contents/Parsers/
  3. Copy & paste the results here. There should be a file called libgecko3parsers.dylib which is used by Firefox.  

The only real difference in Norton Confidential between Firefox and Safari support is that libgecko3parsers.dylib, so something might have gotten corrupted with that file. But the Console output might tell us more.

Thanks,

Ryan 

Ryan McGann Technical Director Norton Business Unit, Symantec
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Ryan, here is what I captured via your instructions for Console:

Aug 19 06:21:19 new-host-2 /Applications/Firefox.app/Contents/MacOS/firefox-bin[1319]: Failed to connect to SymSharedSettings, error 8.
Aug 19 06:21:19 new-host-2 /Applications/Firefox.app/Contents/MacOS/firefox-bin[1319]: Norton Confidential Phishing Protection could not connect to SymSharedSettings: 1
Aug 19 06:21:57 new-host-2 [0x0-0x7a07a].org.mozilla.firefox[1319]: Debugger() was called!
Aug 19 06:24:24 new-host-2 [0x0-0x7a07a].org.mozilla.firefox[1319]: Debugger() was called!

 

 And here is the results from Terminal from your directions:

Last login: Mon Aug 17 23:43:32 on console
new-host-2:~ pcrosta$ ls /Library/Application\ Support/Symantec/WebFraud/WCIDEngine.bundle/Contents/Parsers/
libgecko3parsers.dylib    libwebkit3parsers.dylib
libgeckoparsers.dylib    libwebkitparsers.dylib

I see there is a file listed right above w/o the "3" -- is that a clue?

Any further recommendation??

Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

It looks like for some reason, Firefox is having problems reading the settings file, but Safari is not. It's kind of puzzling really.

My recommendation would be to run this command in the Terminal application:

sudo rm -rf /Library/Application\ Support/Symantec/Settings/1/

This will delete all of your settings, which might be somewhat unfortunate, but it could solve this problem. Let me know if this works, and sorry for the problems.

Ryan 

Ryan McGann Technical Director Norton Business Unit, Symantec
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Things have not changed, Ryan.

I ran sudo rm -rf /Library/Application\ Support/Symantec/Settings/1/

in Terminal, was warned about using sudo ... supplied my password and got the same "Error encountered" in the yellow stripe about the browser window.

Further suggestions?

Pete

Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Oops, chalk this one up to my bad. You need to restart after running the command in the Terminal. Make sure you have no applications open except Terminal, and run that command. Then restart your computer immediately. If you don't restart, the file will just get re-written.

If that still doesn't work, then you might have to uninstall and re-install. That's usually my plan of last resort. It's quite odd that Safari doesn't have any problems, and I don't know why this problem is only affecting you. Hopefully restarting the computer will fix it.

Ryan 

Ryan McGann Technical Director Norton Business Unit, Symantec
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Sadly, no change. I know something was affected after the restart because Norton Firewall asked me to confirm a gazillion things, but when I opened Firefox, still have the same warning.

Any suggestions on the best way to trash Firefox and reinstall w/o losing all my bookmarks?

Message Edited by macuzer on 08-23-2009 07:40 AM
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

If you want to re-install Firefox, you can simply re-download it from the Internet (http://www.getfirefox.com). The Firefox user data such as your bookmarks are kept in a seperate folder.  However you may lose some extensions. You can keep the old copy around to make sure everything transfers over before you decide to delete it. Sadly, I can't guarantee whether doing any of this will make a difference.

Let's take a step back and get some more info first:

1) What version of Firefox are you running?

2) Do you have an Intel-based Mac? 

3) If so, are you running Firefox in Rosetta (PowerPC) mode? You can verify by performing a Get Info on the Firefox application, and making sure the "Open using Rosetta" checkbox is NOT checked.

4) Do you have any other Firefox extensions?

5) Do you have any other 3rd party software installed on your Mac that might perform security functionality?

Let's see if any of this brings up a red flag. 

Ryan McGann Technical Director Norton Business Unit, Symantec
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Model Name:    iMac
  Model Identifier:    iMac7,1
  Processor Name:    Intel Core 2 Duo
  Processor Speed:    2.8 GHz
  Number Of Processors:    1
  Total Number Of Cores:    2
  L2 Cache:    4 MB
  Memory:    4 GB
  Bus Speed:    800 MHz
  Boot ROM Version:    IM71.007A.B03
  SMC Version (system):    1.21f4

Now with all that out of the way, I am not in Rosetta mode.

FF extensions:

 1-ClickWeather 1.1.8

Adblock Plus 1.1.1

AutoPager 0.5.2.2

ChatZilla 0.9.85

ColorfulTabs 3.9.3

CustomizeGoogle 0.76

DownloadHelper 4.6.2

DownThemAll! 1.1.4

Exif Viewer 1.51

IE View Lite 1.3.4

ImageBot 4.0.6

KallOut 1.1.21.26

Kodak EasyShare Gallery Companion 1.4

Map This 0.3.1

Remember The Milk for Gmail 1.0.4

Speed Dial 0.9.1

Toodledo 1.60

Nothing is running in conflict w/regard to security to the best of my conscious knowledge!

If you wish to provide me w/an email address, I can give you a full report on the iMac as well as offer screenshots. Up to you. 

Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

 First, I am not sure why your Firefox is listed as PPC Mac OS X 10.5. In my build of Firefox, when I go to about: I get

  Build identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

Perhaps you are running  a PowerPC version of Firefox on your Intel Mac? This would be the same as running in Rosetta mode. Try downloading the latest version of Firefox from getfirefox.com, and make sure it says its an Intel build when you launch it.

Second, you definitely have a lot of extensions. One thing you could try is making a copy of your Firefox profile, stored in your home directory's Application Support folder (~/Library/Application Support/Firefox). Then delete the original Firefox profile and re-launch Firefox. If the problem with Norton Confidential goes away, then it's probably one of your Firefox extensions that is causing the problem. Just a thought.

Ryan

Ryan McGann Technical Director Norton Business Unit, Symantec
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

It has been a long night. I'll try to recap but I am now at my witts end.

Okay, I trashed the folder you asked about, it asked if I wanted to import Safari bookmarks after restart and I said no, so when FF opened, same yellow Error bar. I figured,it has GOT to be the version so I REPLACED the Firefox folder that you told me to trash w/a backup from time machine (so I had my bookmarks).

I then restarted computer and using Safari went to the URL you directed, downloaded 3.5 again, confirmed the replacement. Computer froze and went into rebuildin permissions from start-up cd, verfied disk while I was at it.

relaunched NEW Firefox and this is what I find:

Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2

I'm clueless. I'm also beyond frustrated. I don't know what to do now. Why I keep getting the PPC version while you have the Intel on your build identifier is just beyond my comprehension. BTW, I did not see anything that said Intel build vs PPC build when I launched anything as you directed.

Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Sorry to hear about the problems. First let's make sure Firefox is actually PowerPC, instead of just going off the build string.

Launch Firefox, and then open the Activity Monitor application on your Mac (it's in Applications -> Utilities). Then find Firefox in the Activity Monitor window (it'll be listed as firefox-bin). Look at the "Kind" column for Firefox. If it says PowerPC, then yes Firefox is still running as a PowerPC application.

If that's the case, there are a couple of things to try. First, make sure Firefox is not running. Then trash your Firefox application. Be sure to delete all copies of Firefox that may be lurking on your computer; you can use Spotlight to find anything called "Firefox.app". After all the copies of Firefox on your drive are deleted from the Trash, and Firefox is not running on your Mac, drag the new Firefox from the Firefox disk image to your Mac's Desktop. Double click this new copy (don't use the Dock or anything like that) and verify it's running as an Intel application and not PowerPC. The Mac OS X database of applications (called LaunchServices) sometimes becomes corrupted, and the Dock and Finder can sometimes launch the wrong version of an application,.

Second, make sure Firefox is not set to run in Rosetta. Perform a Get Info command on your copy of Firefox by selecting it, and then selecting Get Info from the Finder. Be sure that "Open using Rosetta" checkbox is NOT selected. If it isn't selected but Firefox is still running as PowerPC, then it might be that LaunchServices might be corrupted still. There are other things we can do to fix that.

I verified that when I use Rosetta to open the PowerPC version of Firefox on my Intel iMac, Firefox's build string says "PowerPC" and I get the "Error encountered" toolbar message, so ti sounds like this definitely could be the problem.

Ryan

Message Edited by ryan_mcgann on 08-25-2009 12:03 AM
Ryan McGann Technical Director Norton Business Unit, Symantec
Kudos0

Re: Confidential (Mac) ERROR ENCOUNTERED v1.2.2 (25)

Well, all is well in Oz. Activity Monitor showed exactly what you predicted. So I was going to trash all as you prescribed, but instead, simply unchecked "Open using Rosetta" - this was already checked on. No clue how it got checked or why. I did not trash anything. Now Confidential is working as normal. Nice to see the green bar on top! :-)

Ryan, thank you for your tenacity on this problem. I so greatly appreciate your time and energy. THANK YOU, THANK YOU!!!!!!

Pete

This thread is closed from further comment. Please visit the forum to start a new thread.