• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

Firewall 4.1.0 (33) not working well with Time Capsule / Time machine

Hi all! I upgraded my Norton Internet Security for Mac a few days ago through LiveUpdate, and the new firewall (4.1.0 (33) ) does not seem to like Time Capsule a lot... Actually, I do have to turn off both connection blocking & application blocking so the normal back up can work. (Monitoring the connections through NIS Connection window lead me to find out that only when both App & Connection blocking were Off, the back up would work normally. )

How can I provide the right rule, so these connections can take place as they used to before the update, without having to turn App & Connection blocking off?

I allowed all that NIS asked me to allow and it is still not working. Actually, I don't know if it is a bug, if it is the back up process that is seen as a suspect behavior by NIS (even though I can't find any report of this) or if I need to add more specific rules (such as allowing the "mach_kernel" app, but as it is invisible, I don't know how to autorize it - this is the app that shows up in the connection monitoring windw in NIS, when I am doing the backup-up, with the Apple File Sharing service on port 548).

Any help would be appreciated! 

Thanks,

Alain 

Replies

Kudos0

Re: Firewall 4.1.0 (33) not working well with Time Capsule / Time machine

Hi Alain,

I'm assuming that your are backing up over the network.   It is possible that you have a rule in your firewall that's blocking the outgoing connection to your time capsule (outgoing port 548.)  If you have trouble configuring it, you can send your firewall ruleset, I can take a look for you.  (Go to File->export and save the file.  Place the file in an archive and attach it to the email)  My email is plin@symantec.com 

Alternatively,  you can try adding the IP address of your Time Capsule to the Firewall's Trust zone.  You can do this by going to Firwall Settings->Connection Blocking->Configure...->View Zones->Add IP Address...->Allow A single computer and enter the address of your Time Capsule.  Doing this will make the firewall "trust" your Time Capsule and ignore all other rules for your Time Capsule only.

As for Application Blocking, there are several processes that need to be allowed in order for backup to work.  From looking on my computer that's running Leopard 10.5.8, I can see that they are: check_afp, backupd, NetAuthSysAgent, NortonAutoProtect.bundle.  Typically, the firewall will ask you to allow them when the backup process starts.  If you don't have these added, please let me know via email and I will help you add them.

Paul

Kudos0

Re: Firewall 4.1.0 (33) not working well with Time Capsule / Time machine

Paul, thank you! 

Promising solutions here. I will send you the firewall ruleset and will try the TimeCapsule IP  address to the Trustzone.

Al. 

Kudos0

Re: Firewall 4.1.0 (33) not working well with Time Capsule / Time machine

Hi Paul!

I sent you the requested file a long time ago. Have you had a chance to look at it?

These days, I turn off Application Blocking and connexion blocking most of the time. It's the only way  I can have both Time Machine and iTunes (through Airport) to work correctly... : (

Al. 

Kudos0

Re: Firewall 4.1.0 (33) not working well with Time Capsule / Time machine

Hi Al,

Sorry for the delay.  I just read your email.  The Connection Blocking rule set looks OK.  If you turn off Application Blocking but leave Connection Blocking ON, does Time Machine backup work?  Also, what OS are you running (10.5.x or 10.6.x?)  How are you connected to your time capsule?  (Wired or wireless)  I will try to replicate your setup in our lab.

Thanks.

This thread is closed from further comment. Please visit the forum to start a new thread.