• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

Firewall traffic rules not enough for WinRM

I am trying to connect with WinRM between two Windows 10 (build 1607) with Powershell 2.0. I have everything setup and everything works fine with Norton Security Smart Firewall (NSSF) deactivated. I do not know, however, how to configure it to work together with Smart Firewall.

WinRM uses port 5985-5986 for communication and these are successfully forwarded from my router. No other ports are forwarded, WinRM can therefor not use any other port for communication.

I have added two traffic rules to NSSF. One for local and one for distant communications. Both opens up port 5985-5986 for to and from all computers with all protocols. Still, with these two rules (local+distant), I can not establish a connection with NSSF activated.

EDIT: The exception was only added to one of two Norton Secured computers. Rule has to be added to both computers.

Replies

Kudos0

Re: Firewall traffic rules not enough for WinRM

Hello,

I assume you have network trust level set to "Public". You can verify it through Settings->Firewall->Network Trust->Configure,

There is a way to allow WinRM through enabling an exception known as "Windows Web Services" through Settings->Firewall->Traffic Blocking Exceptions->Configure->Check the box next to "Windows Web Services". Try this by removing your customer rules and let us know the result.

If "Windows Web Services" is disabled in the second computer also, you can follow the same procedure as above.

Thanks,

This thread is closed from further comment. Please visit the forum to start a new thread.