• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

 Just an observation on 22.10...

Manual LiveUpdates under v22.10 have (for me) been turned into total slug-along/snail-race activity. And this is now the "less than pleasant" situation I have to deal with on all of my Win-10 and Win-7 systems after they received/updated to today's v22.10 release.

Curious to know if anyone else is noticing that manually running LiveUpdate is suddenly taking a uncharacteristically

. . . v e r y   l o n g   t i m e . . .

to check for product updates (for me, NSwB) after receiving the v22.10 update today? Before the update installed all was well and operationally normal with the NSwB installations, and FWIW all other installed products (e.g., Windows Update, Adobe Update, etc., etc., etc.) continue (update-wise) to still zoom along at their normal/expected "==VERY FAST==" paces (my BB download speed is 350-MBPS).

So - Hopefully this will not prove to be the new "as expected" behavior adoption of LiveUpdate henceforth...    

Cheers!

Labels: Performance

Replies

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

G'day Johnnie,

Yep, I have the same slowness on my machines too.

A little bit of knowledge is... well a little bit of knowledge.
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Same longer manual LiveUpdate here too.

Windows 7 HP SP1 32-bit | Chrome 65.0.3325.146 | NS 22.12.1.15
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Check for updates OK

Download update     ok

Process updates takes for ever

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Check for updates OK

Download update   OK

Process updates takes for ever

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

As far as I noticed from other people updating to 22.10, some form of traffic or download throttling is happening, not certain on this issues. But it appears that majority of people doing updates are affected.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Thanks to all respondents for your "==VERY FAST==" issue-similarity confirmations!  

Seems that we're all similarly-mired in this new "fine mess".  

Cheers!

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Processing seemed extremely long for the past few days (even prior to 22.10.0.85).

However now I am getting a failure on Extended File Attributes and Signatures download from LU.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

G'day Yank,

I just did a manual LiveUpdate and although it successfully found and downloaded the Extended File Attributes and Signatures update (plus one other):

It then took several minutes to process/install just these two downloads...

However, the Server transaction (check, download) phases seemed quite a bit faster than what was happening here yesterday - though still much slower than the expected/previously-normal download & process times.

Seems there's more going on here than just slow LiveUpdate Server transacting?

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Just chiming in that I've been seeing the same thing over the past week or so.  Downloads seem fast, but the checking and processing made me think something was wrong with my NS software

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Hi everyone,

Thank you for reporting this issue. The team is looking into it.
I've sent you a Private Message requesting logs, Please check it when you get a chance.

Mohanakrishnan G | Norton Forums Administrator | Symantec Corporation
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

I have uploaded requested log.

A little bit of knowledge is... well a little bit of knowledge.
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Artifact of LU-PM (Release 22 Version 10.0 unstable? 83)

Release 22 Version 10.0 patch 85 was out about less than a day when this thread started. The edited Release 10.0 patch 85 with the LU-PM disclaimer. Perhaps Phased Manner has two steps, first, as sample that is either for a period of time that everyone for a set number of hours, or a proportionally weighted representative sample of the range of operating systems. At some time it goes from NARROW to WIDE distribution, then it's available for NortonDownloadManager product delivery.

WIDE multiplies the traffic on the LU servers. I started a double un-install single re-install about a half hour after dot 85 was announced. I had received an e-mail about a new post by SoulAsylum in this thread at 17-Jul-2017 | 3:20PM  https://community.norton.com/en/forums/version-2210083-problems .

The double un-install was because do overs (to get back to stable 22.9.4.8) had left my Start>all programs with a LISTINGS for Norton AntiVirus Online AND Norton AntiVirus  drop list headings for features that each ran, the same applications in the Norton AntiVirus folder.

22.10.0.85 installed as announced in just under two hours yesterday. I ran  LU x3 on my Win 8.1 laptop after I started this comment. Those LU's got the 22.10.0.85 in under 15 minutes, protection definitions, then patch DL, then the final LU, an extra LU interactive reported no more to get. There were no restarts required. The summer 2015 PM left my system restricted for over a week. It also took the LU servers down for extended times, more than once, before WIDE  happened. This is just a predictable service slowdown after a PM pull and new patch.

J

(Krusty13 posted while I was composing this.)

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Krusty13:

I have uploaded requested log.

Thanks for the logs, Dave. I appreciate it.

I've passed it on to the team. I'll ask for more if needed 

Mohanakrishnan G | Norton Forums Administrator | Symantec Corporation
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Just a quick update.  My Extended  File Attributes and Signatures updated via Auto LU successfully 15 minutes after they failed.  I got busy with some outside chores and never got back to this PC until this AM.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

FWIW, my LiveUpdates seem to be working normally again (on all my previously affected systems). This correction appears to have happened sometime during the day yesterday while I was away at work (Note; I'm in the U.S. Pacific timezone).

I noticed the "return to normal" when I manually checked LiveUpdate after getting back from work, and everything was back to "speedy mode" at that time. Thus far, it has stayed "speedy", thankfully.

Cheers!

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Yep. Running ok here in Australia.

Windows 10 Home X 64
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

After yesterdays full uninstall and reinstall it is fixed here as well. Seems like we are back to normal working conditions  

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

I also noticed some improvement yesterday morning (local time) and today I can confirm manual LiveUpdate is definitely back to normal for me.

Windows 7 HP SP1 32-bit | Chrome 65.0.3325.146 | NS 22.12.1.15
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Back to normal?  Well, let me say, the Check and Download are rapid, the Process is about the same as before - but I sit here waiting for the View Summary for over a minute on my NS Premium on WIN 10.  The View Summary does not take any longer than it used to on my NSS WIN 7 system.

Anyone else experiencing the long delay for the View Summary?

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

G'day Yank,

For me the Check and Download phases of a manual LiveUpdate are back to normal (expected) full speed.

Depending on what was downloaded, the Process phase (time to install) varies.  Web related items do seem to take a little longer to process than previously - e.g.: Items like:

Perhaps these updates are just bigger (more to process) than they used to be, or maybe getting them inserted into the newer detection engine (while its active/running) is a little more involved than it used to be?

John

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Thanks for your reply John and I do agree with your thoughts as to the possible causes.  I can actually live with that, but I was questioning why it takes so much longer for the View Summary to show up. 

These are the downloads that drug the View Summary out for me this AM:

I have gotten into the habit of checking the View Summary after each LU instead of going thru History to see what was up-dated.

Kudos1 Stats

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Hi Yank,

I (typically) check the History log if/when the occasional "LiveUpdate Failure" occurs - something (for me, fortunately) that does not occur very often.

However, I do have the habit of checking the "View Summary" after every manually initiated LiveUpdate completes it activities (if any were done).

At your suggestion, I took a look at a few recent History / LiveUpdate / Details log entries - I did not notice any delay in the expected report generation time ... but now that you've drawn my focus to that particular point of interest, I'll keep an eye on it for while - If I notice any operational delays I'll certainly post back here regarding the observation.  

Cheers!

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

That would indeed explain the possible slow down. I will be waiting for AVJohnnie's observation summary, would be interesting to see if we can find the true reasons.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Hi John and Josh Ross,

I timed my appearance of "View Summary" after a manual LU which contained 7 updates - took a bit over 1 minute and 30 seconds to appear after the Process Updates showed Completed.  Since I had the watch out, I noticed not only the length of time to view, but also the clock time.  This on a WIN 10 CE running NS Premium,

It appears to me that the History entry for that LiveUpdate displays the beginning of the LU, not the completion. 

I also checked the initial manual LU History on a WIN 7 system running Comcast NSS (22.10.0.85) and it also showed the start time of the LU - not the completion time.

So it appears to me at least, that a delay in the View Summary appearing, would not be shown in the LU History.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

G'day Yank,

After numerous History log checks I concur with your finding Yank - It appears the History log entry is made upon job/task initiation, not upon task completion, unless at least one of the associated sub-processes affiliated to the task errors for some reason - so agreed; no joy gained by following that route for this particular diagnostic purpose.

I have thus far been unable to correlate any performance interactions between "longer duration" manually initiated LiveUpdate "Processing phase" activities and the time it takes to generate the "View Summary" report afterward...

For me, the "View Summary" has always produced its report expeditiously.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

A quick clarification question Yank,

Is the delay you're getting occurring after all three phases show green checks, but the overall processing status indication remains "Yellow" and the "View Summary" link takes much longer than what would be considered normal before it finally appears, e.g.:

Or does the long wait that you're getting happen after you've clicked the View Summary link on the Green "LiveUpdate finished" display, before the summary detail is actually displayed, e.g.:

Thanks,

John

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Hmm.. that's when it is done installing updates and is cleaning up the temp files from the update. How many seconds does it spend there for you?

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

John - your first image - that is where the long delay (almost 1 1/2 minutes) is occurring.

Once I get the "View Summary" it almost instant shows up!

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Mine has always hung on Finishing processing, and always on the last update.

On ALL versions, I might add.

Never for more than maybe 15-20 seconds, depending on how many updates there have been.

Windows 10 Home X 64
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Interesting, that logs do not show the actual full time for it. I will have to time my updates at some point as well, to see the time, but I would assume it shouldn't differ much from any of you guys.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

password_password:

Hmm.. that's when it is done installing updates and is cleaning up the temp files from the update. How many seconds does it spend there for you?

Typically 2 to 3.

FWIW, When I was having the big delays a few days ago they were occurring on the "Check for updates" phase and on the "Process updates" phase. But even then, once I had 3 green check-marks showing on the phases, it only took another couple of seconds (3 at the outside) to transition to the all green ready to View Summary display.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Yank,

At this point I'm in agreement with poster password_password. I think that you are getting some sort of post-processing LiveUpdate cleanup-phase delay, presumably newly induced (for some) by the latest engine update.

It may be possible that the root-causation would be revealed by using the Norton diagnostic log gathering tool/procedure suggested earlier in the thread by Mohan.

However - If you just as soon avoid dealing with that (and I'm not really certain how you'd get any "revelation findings" reported back to you individually anyway); then perhaps using the NRnR tool (assuming of course that you haven't already done so)...

John

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

John, totally agree that an NRnR run will be coming soon - but I noticed something this AM.

Being a creature of habit - I run a manual LU after initial boot up each day.  This LU this AM exhibited the reported delay of the green header and View Summary.  I have run two manual LU's over the past hour and the delay was not exhibited. 

OK - so perhaps I should wait longer to run the initial manual LU - ensuring the PC is totally booted up and ready to go to work.  I'll try that tomorrow AM.

Also I am going to start looking more closely at which updates re present when the "delay" occurs.  This AM Anti-Spam Defs was the item present in the delayed View summary and not present in the last 2 LU's which went green as expected.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

FWIW Yank, my systems, at startup (according to my occasional LiveUpdate history-log interrogations,) almost immediately perform an automated LiveUpdate run - yet even-so (knowing that,) I also have adopted the habit of doing a manual LiveUpdate right after system startup.

As to the LiveUpdates that take the most time to process, for me those typically are the Web related updates and the Anti-Spam def updates - save of coarse the occasional new engine version update...  

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

As an update - I waited 10 minutes for thing to calm down after boot up this AM, helped some, but still took about 35 seconds for the View Summary to appear.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Hi yank,

Been keeping an eye on this thread as I too noticed some time ago it was taking longer than normal to implement updates. Just now thought I'd give this a try and for what it's worth it also took around 35 seconds for my view summary to appear! This was for one update, 'Norton Web Protection Def's'.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

brummie (et all),

Anti Spam defs received in first manual LU this AM and once again over a minute for "View Summary".  

Just did another manual LU and without Anti Spam defs - took about 10 seconds.

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

Guestimation, what if they changed the way they are implementing updates? Maybe there are a lot more signatures that can/need to be covered. Additionally, it can be doing one or more additional checks than before, making it either more thorough or more accurate?

Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

For me this issue with long run LiveUpdate has been totally solved.. it runs super fast now! 

Kudos1 Stats

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

For me this issue with long run LiveUpdate has been totally solved.. it runs super fast now!

Thanks for confirming, @got3n & @avjohnnie

Others,

If you are still facing this issue, please let me know.

Mohanakrishnan G | Norton Forums Administrator | Symantec Corporation
Kudos0

Re: Since getting 22.10.0.85 LiveUpdate takes a very long time to run...

I wouldn't say Live Update is "super fast", but it appears to be back to normal here.

A little bit of knowledge is... well a little bit of knowledge.

This thread is closed from further comment. Please visit the forum to start a new thread.