• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos1 Stats

Ghost 15: E98F002C when trying to mount a backup image file

My problem was similar to one titled "Ghost 15 Backup Destination Problem" which is labled as solved, so I could not post this addenda to it.

The above thread did not have the final piece I seemed to need to get mounts and dismounts to work properly.

Environment:

  • Brand new Dell laptop
  • Windows 7 64-bit with all current Microsoft Updates installed
  • Brand new, Boxed, Norton Ghost 15 showing as: 15.0.1.36526. Symantec Update shows this to be current
  • GenericMountHelperx64.exe showing as: 1.0.0.36225
  • Ghost Backup of my old machine, created using the Norton Ghost 9 installed on that old machine.

Problem Outline:

On the new Win7 machine, I was successfully using the Ghost15 browser to inspect files contained in that backup

When I tried to mount the backup file on the Win 7 machine from within the Ghost 15 image browser:

  • I got a display indicating that Norton Ghost was being configured. (not expected!)
  • I got the E98F002C error.
  • The mount appeard to have succeeded. I could view directories and open files from windows explorer.
  • When I tried to dismount the image I got the "no information" failure described in the above referenced thread.

It took a windows restart to dismount the backup file.

Attempting to mount the backup via windows explorer failed.

Having found the above problem thread, I went to Services and determined that I did not have an entry for a "GenericMountHelper" service listed.

I then went to the Control Panel-> -> Programs and Features and invoked Repair for Norton Ghost.

When that completed, Services showed a "GenericMountHelper" service with startup type "Manual".

I again attempted to mount the backup from withing the Ghost15 browser. This resulted in the same unexpected Ghost configuration sequence, the E98F002C error, and a mounted backup file  that I could work in via windows explorer but could not dismount.

Inspection of Services no longer showed a "GenericMountHelper" service.

I restarted the machine to get the file dismounted, Inspected Services to verify that there was no "GenericMountHelper" service, andi  performed the Repair on Norton Ghost again.

This time I restarted after the repair completed. Inspection of Services again showed a "GenericMountHelper" service  with startup type "Manual".

Another mount try, same problem.

Repair, Restart...

I decided to try something different.

I manually started the "GenericMountHelper" service. No "configuration" messages. Service showed as started.

Once again I attempted to mount the backup from within the Ghost image browser.

- - >  Success! and No Errors reported!

I attempted a dismount. Also Success! and No Errors Reported!

I manually stopped the "GenericMountHelper" service.

From with in Windows Explorer I navigated to the backup location and mounted it. Success and no errors likewise the  dismount.

I returned to the image browser. Again I was able to mount and dismount the backup from within the image browser.

- - >  Mounts and dismounts have worked correctly ever since.

My guess is that by manually starting the service something got set somewhere in the registry or within the Norton Ghost environment that was not properly set during the initial install or subsequent repairs. And that this "something" was what caused the mounts to invoke the Ghost configuration sequence that appears to have killed the "GenericMountHelper" service.

Inspection of Device Manager-> Generic Mount Devices shows two "Generic Mount Control Device" entries, each flagged  with a yellow triangle with exclamation point. When I open properties on either of these, I see "This device is not  working properly because Windows cannot load the drivers required for this device. (Code 31)".

From the View menu I turned on "Show Hidden Devices" which revealed a third "Generic Mount Control Device" entry which does not have the yellow triangle and whose properties indicate that it is working properly.

A registry scan shows that there are now many seemingly duplicate entries with "GenericMount" or "Generic Mount" as the searchable key which are all tagged as being "Symantec" related.

Bottom Line:

At least in my instance, the trick was to manually start the service at least once before trying to mount anything. It would appear that by doing so (I was logged on under an admin ID) things got loaded/configured where they belonged.

Speculation on my part:

The CODE 31 seems to indicate that the "Ghost configuration" sequence that was launched for the first "GenericMountHelper" service start after install/repair (invoked by way of the first attempted mount) did not run at high enough authority to configure/load the necessary bits.

Replies

Kudos0

Re: Ghost 15: E98F002C when trying to mount a backup image file

Good detective work! In services.msc, my GenericMount Helper Service is set to manual. If I mount an images as a drive letter. it starts. When I dismount the image, it stops. No errors for me. I did have a problem a long time ago, but I think running the fixinstall.bat file took care of it.

Kudos0

Re: Ghost 15: E98F002C when trying to mount a backup image file

When you were doing all of this, were you testing with the same recovery point set? Is it possible that when the mount started working, a new recovery point had been created? We need to rule out something being wrong with the recovery point set.

As for the devices with the yellow ! on them, you can likely remove them.

-Andy
Kudos0

Re: Ghost 15: E98F002C when trying to mount a backup image file

Good morning,

I just looked at the available recovery points and compared the dates to my system maintenance journal.

There is a recovery point created by the original Ghost 15 install on 6/8/2012. The next available restore point was created on 6/13/2012 by another software install.

The morning of 6/11/2012 was the first time I tried to mount a backup file. All of the trouble shoot work and arrival at my apparent solution took place the afternoon of 6/11 after I had researched the error code via GOOGLE which found hits on this web site and elsewhere. 

- - > Editorial comment based on 40 years of IBM Mainframe and Windows PC system work:

If you do not keep a time line journal of what you do to your system and software, you are going to be just guessing about what you actually did when things come apart.

I believe that this journal should be kept by hand and on paper because if you only have one system and it is down hard, you may not be able to access your notes from an on-disk journal when you really need them!

Kudos0

Re: Ghost 15: E98F002C when trying to mount a backup image file

Well, the error indicates something in the recovery point chain, or the RPAM file. One thing you can do since  it appears that you have various recovery point sets is to start a fresh job, and begin backing to a new folder. That will reset the RPAM file to the new job and new location. Once you have one backup complete, attempts to mount that new image file.

-Andy
Kudos0

Re: Ghost 15: E98F002C when trying to mount a backup image file

Good morning Andy!

I am not sure where you are going here.

I believe that I have resolved my problem. 

My original post was intended to provide both users and developers with additional, hopefully useful, end user subjective experience information.

So lets review the bidding here:

  • After performing the Windows Repair (via Control Panel\All Control Panel Items\Programs and Features) of the Ghost 15 installation and then manually starting and stopping the the "generic mount helper" service that one time on 6/11/2012, as described in my original post, I can freely navigate to, and then mount and dismount Ghost backup images.
  • No errors are being generated; regardless of whether I perform the mount or dismount from the Ghost Image Browser or from the Windows Explorer.
  • I have not had to manually start or stop for the "generic mount helper" service since that one time on 6/11.
  • No additional devices with yellow exclamation marks complaining about not being able to load drivers have appeared in the device manager.
  •  While I was having the problem, the requested mount happened. I could work with the directories and files in the mounted Image. I would guess from this "successful" mount that the actual error was happening in the generic mount helper service code some where after the mount request had been handed over to Windows for processing, but before normal completion of the service process.
Kudos0

Re: Ghost 15: E98F002C when trying to mount a backup image file

Addendum:

I have multiple Ghost 9 full backup recovery sets from my old machine spread across several external drives that I rotate to a remote storage location.

After my "fix", using this new machine I can navigate to and mount any of the images on the external drive currently in house. 

I think I misunderstood your earlier question about restore points. When I replied I was refering tothe Windows System recovery points frequently generated as part of software installs or Windows Update activity.

As of 6/20/2012 I have not yet attempted a Ghost 15 backup of any kind. So that type of activity could not have been involved in fixing my problem.

Kudos1 Stats

Re: Ghost 15: E98F002C when trying to mount a backup image file

Continuing Adventures with Generic Mount Control Devices

To cure a registry problem with another piece of software, I performed a windows system restore to a restore point taken prior to the initial install of Norton Ghost.

As expected, this effectively uninstalled Norton Ghost.

From the experiences described in my earlier post, I figured I knew what steps to take to install Norton Ghost and to get a clean setup for mounting a Ghost backup without errors.

HA!

I installed Norton Ghost 15.using my system administrator id:

  • Started Norton Ghost, Configured Options, Stopped Ghost
  • Started and stopped generic mount service
  • Started Ghost browser
    • Browsed ghost backup image
    • Mounted backup image
    • Dismounted backup image
    • At this point everything looks good!

Alas, not entirely true.

Reboot to my normal user id.

  • Started and stopped generic mount service
  • Used windows explorer to navigate to a Ghost backup
  • Tried to mount the ghost backup under windows explorer
    • Message that Norton Ghost was being configured
    • Mount did not happen
    • Generic mount service had disappeared!
    • Perhaps I should have started/stopped ghost first to allow initial “configuration” for this userid

Reboot using system administrator id.

  • No generic service
  • Mounts fail

Apparently the configuration process under my normal id (with a mount pending) once again wiped out the generic mount service

  • Repair Norton Ghost.

Reboot as system Administrator

  • Generic mount service is once again visible
  • Device manager shows one disabled generic mount device and one enabled generic mount device
  • Start/Stop Ghost
  • Start/stop service
  • Start ghost recovery browser
  • Successful mount and dismount of a ghost backup
  • So I am sort of back where I started

Reboot to my normal user id.

  • Start / stop Ghost
    • Message asking if this user id should be able to use ghost in other than read only. replied yes.
  • Start/stop generic mount service
  • Start Ghost browser
  • Mount/dismount a ghost backup
  • Shut down ghost browser
  • Looks like all is now working as advertised 

Bottom line take-away bits:

  • After new install or repair:
    • It may or may not be necessary to mess with the generic mount service for each user id on the system as long as at least one user has manually started and stopped the service before ANY ghost backup mount activity has been attempted
    • Looks like one should start Ghost once in each logon id that may have a need to use a mounted ghost backup before one attempts to mount a ghost backup in that user id. This may also apply any time you subsequently add a new user id to the system
  • To clean up the broken “Generic Mount Control Device” (Windows 7)
    • Navigate to Device Manager
    • Under View on the menu bar select “Show Hidden Devices”
    • Double click on “Generic Mount Devices” to show all devices in the category
    • Right click on the Generic mount control device with the yellow triangle containing the exclamation point (flag for a broken device)
    • In the context menu, Click on “Uninstall”.
    • In the confirmation dialog box, make sure the check box to delete the driver software is NOT checked.
    • Click OK

This thread is closed from further comment. Please visit the forum to start a new thread.