• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

High CPU usage in Explorer.exe when right clicking on certain files with AV auto-protect enabled.

I've noticed for a while that when I right click on certain files, that explorer starts using a lot of CPU time and the right click menu can take up to 30 seconds to display.  I finally tracked the problem down to Norton Internet Security 2008.  If I disable Anti-virus auto-protect the problem goes away.

I used SysInternal's Process Monitor to see what was going on during the high CPU usage time and I see explorer.exe is continuously accessing the following files during that time period:

C:\Documents and Settings\All Users\Application Data\Symantec\SRTSP\SrtETmp\936A91F3.TMP

C:\Program Files\Common Files\Symantec Shared\VirusDefs\20080905.023\VIRSCAN7.DAT

So it seems to be scanning for something, but gets stuck repeating the scan over and over again.  Explorer stops responding, but eventually the right click times out and no menu appears.

An example of a file this occurs for (and the one I just saw) is the MediaCatcher.exe file installed by Replay Media Catcher.  It seems to be scanning each program registered to display an entry in the right click menu,

I found a work around which is to disable auto-protect, then right click the file and choose  "Scan with Norton Internet Security" and then I can re-enable auto-protect and right click the file without the high CPU usage.  Apparently Norton will flag it as okay once I manually scan it, but not when it's automatically scanned.

Replies

Kudos0

Re: High CPU usage in Explorer.exe when right clicking on certain files with AV auto-protect enabled.

I've noticed for a while that when I right click on certain files, that explorer starts using a lot of CPU time and the right click menu can take up to 30 seconds to display.  I finally tracked the problem down to Norton Internet Security 2008.  If I disable Anti-virus auto-protect the problem goes away.

I used SysInternal's Process Monitor to see what was going on during the high CPU usage time and I see explorer.exe is continuously accessing the following files during that time period:

C:\Documents and Settings\All Users\Application Data\Symantec\SRTSP\SrtETmp\936A91F3.TMP

C:\Program Files\Common Files\Symantec Shared\VirusDefs\20080905.023\VIRSCAN7.DAT

So it seems to be scanning for something, but gets stuck repeating the scan over and over again.  Explorer stops responding, but eventually the right click times out and no menu appears.

An example of a file this occurs for (and the one I just saw) is the MediaCatcher.exe file installed by Replay Media Catcher.  It seems to be scanning each program registered to display an entry in the right click menu,

I found a work around which is to disable auto-protect, then right click the file and choose  "Scan with Norton Internet Security" and then I can re-enable auto-protect and right click the file without the high CPU usage.  Apparently Norton will flag it as okay once I manually scan it, but not when it's automatically scanned.

Kudos0

Re: High CPU usage in Explorer.exe when right clicking on certain files with AV auto-protect enabled.

Hi Morac,

It would be a good idea to first try contacting our Customer Support team through the product's Help & Support link. Or you can visit the below site to contact our free Customer Support:

http://www.symantec.com/norton/support/selectproduct_ts.jsp

If you have already done this and they could not resolve your issue, please let us know. If this is the case, please provide as many details as possible, for example the operating system and exact product version you are using. There is an update for Norton Internet Security 2008 at http://www.symantec.com/newnis that contains many fixes. Thanks!

Tony Weiss | Norton Forums Global Community Manager | Symantec Corporation
Kudos0

Re: High CPU usage in Explorer.exe when right clicking on certain files with AV auto-protect enabled.

I resolved the issue myself.  See the last paragraph in my original post.

I'm just letting you know what problem I saw and how I fixed it.  The fix wasn't exactly obvious.

This thread is closed from further comment. Please visit the forum to start a new thread.