• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

My home network is connected via Motorola cable modem to Cox ISP.  My client is Win 8.1.  I am experiencing slow DNS lookups which is adding 30-40 percent to my Web page load time on busy commercial pages.

I have verified correct (per ISP) DNS responder settings, and checking with Gibson's DNSBench indicates they are working and performing well (i.e. low average and max lookup times.)

But I still get 4-5 second individual site lookup waits, even on things like google.com and amazon.com. I even get "server not found" errors on such sites.

My wife, on the same network also running Win8.1 BUT NOT NORTON 360, doesn't s\seem to have the problem.

Is Norton 360 doing some extensive checking on the calls to the DHS servers?  Is there some trust or other firewall setting I can do to eliminate the delay?

Thanks!

Replies

Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

Are you and your wife both using the same browser?

Are both computers connected to the network by the same method?  ie ethernet cable or wifi?

You can test to see if it is 360 causing the problem by right clicking on the Norton icon in the system tray, and clicking Disable Smart Firewall. Choose 15 minutes as a time frame and then test your web page load times. If there is no difference, then Norton is probably not involved.

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

What makes you think the delay is in the DNS lookup?

Have you done comparisons with the IP addresses?

http://216.58.216.46  (google)

https://www.google.com

http://54.239.26.128   (amazon)

http://www.amazon.com

Those IP's may be local to my location (Southern CA)

Dave

Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

DaveH--thanks for the reply!  

I am relying on the status indicator of the Firefox and Thunderbird screens that display "Looking up [some-url]", "Waiting for [someWebsite]", [Transferring data from [someWebsite]" etc.  The "Looking up" . . . messages are what I'm attributing to DNS response times. And these sometimes last 5-6 seconds or even time out to display the "Server not found, check your spelling and try again" error page.

I don't think the issue is Netscape (Firefox and T-Bird) because my wife, also on Win 8.1 and also using Firefox, does not seem to have the same issue. She is, however, running a different AV product.

Again, thanks for the suggestion!

Martin

Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

Did you try disabling Smart Firewall as I suggested above?

What kinds of connections are you and your wife using? Wifi, ethernet?

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

Peterweb-Thanks for the suggestions.

Yes, my wife and I are using the same browser (we actually both use multiple browsers but I tested with Firefox on both because Firefox provides those helpful connection status messages during page loads...) We are also on the same ethernet subnet, though we also have a Wifi subnet in the house working off the same Motorola cable modem.

I switched off the Smart Firewall for 15 mins, as you also suggested. Quick testing indicates some but not all lookups still taking well over the maximum time reported by DNSBench (which are all sub-second for configured primary and secondary responders.) Performance might be a tad better overall, but then it's the weekend (Saturday AM) so probably aggregate Internet usage is relatively low. I'd say turning off the Smart Firewall is not the fix.

However, I should note two additional things (not new, but didn't mention before): 1)  not all lookups are slow--some just flash on-screen and sometimes I don't see the "Looking up .  . ." message at all, which I take to mean it's so fast the message doesn't get posted before it's superseded by the "Transferring data from ..." message. And 2), I noticed sometimes more than one lookup on a single Web page build of the SAME site (usually ad-related.) Odd that this is not apparently found in the cache, isn't it?

Question for you: apart from Smart Firewall, is there any other component or function of Norton 360 that might affect a DNS lookup transaction??

Again, thanks for the suggestions!!!

Martin

Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

There should not be any other Norton feature that could be slowing DNS. You could try disabling the Norton Auto Protect along with the Smart Firewall to see if there is any difference. My initial thought is that if the Smart Firewall is not affecting things, it could be some other software or utility that only you have on your computer causing the issue.

What DNS settings are you using? Have you tried another DNS service for testing?

You are using FF because of the messages it gives. Are you able to detect the same slowdowns using another browser?

Have you tried disabling all FF add ons, then adding one at a time till you see the problem?

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

peterweb--

1. no apparent good effect from switching off both Auto Protect and Smart Firewall.

2. I have experimented with other DNS resolvers like Google's and others. Again no apparent help.

3. I haven't yet tried disabling the FF add-ins.

I think I'll take a break on this problem for now and see if something else occurs to me.

Again, thanks for your suggestions!

Martin

Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

My first thought is that if Autoprotect and Smart Firewall are disabled and there is no change, it would indicate that Norton is not involved with your issue. I guess the only way to be sure would be to uninstall 360 and test. If you want to try this, let us know so we can make sure you are still protected while you test.

Try disabling all FF add ons first.

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

Hello

I don't use Firefox, so this is a wild guess. Is it possible that with the changes that Mozilla is in the process of doing that it affects things like DNS servers also as it must affect Norton ID Safe? Since everything has to be rewritten to work with Firefox, perhaps DNS is behind in making any necessary changes? Just guessing on my part.

Thanks.

Success always occurs in private and failure in full view. Windows 10 Pro 64 bit Norton Core Security Plus 22.18.0.213 Core Firmware 282 I E 11 Chrome latest version.
Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

Peterweb--thanks again.

Just FYI, I did get some relief by flushing the Windows DNS cache (ipconfig /flushdns).  But it does not seem to last . .  And really strange is that I get a delay looking up my provider's own pop server in Thunderbird (also a Mozilla product like Firefox, of course.) And for some reason after looking it up, that address does not appear in my DNS cache (ipconfig /displaydns).  Clearly I don't understand how this stuff works. But I am pretty much prepared to let Norton 360 off the hook at this point . . .<g>

Kudos0

Re: How can I configure norton 360 to avoid slow dns lookups on home network w windows 8.1

floplot--thanks for the suggestion!  I do think revisions implemented by different vendors lose synch at least for a while pretty often. If that's the case, presumably the vendors fix the issues once several of us users experience and report them . . .  This one has been bugging me (so to speak) for several months, but I don't see lots of similar reports (here, or in Mozilla fora) so maybe it's a "personal problem" as they say.

Anyhow, thanks again for your suggestion!

This thread is closed from further comment. Please visit the forum to start a new thread.