• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

Hi!

I have 75/75 internet speed thru my internet carrier. I have run all possible scans, Norton Full Scans, Norton Power Eraser, cleaned my cookies, optimized my disk, used my Windows Defender and then disabled after using. (Which removed a virus "BrowserModifier:Win32/KipodToolsCby" - (malware) Norton didn't detect?) My issue is that my 75/75 internet connect is still taking too long to load. Can someone please help me?

Many thanks and appreciation. 

Replies

Kudos0

Re: I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

Please check your internet speed using a wired connection (do not check speeds using a wireless connection), preferably using the speedtest page provided by your internet service provider.  If your ISP does not provide a speedtest, use http://www.speedtest.net/.  Let us know the results.

Kudos0

Re: I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

I did just do that as a matter of fact. I have a desktop computer, I do not use a wireless connection via a lab-top.

Download Speed - 84.06 Mbps

Upload Speed - 91.06 Mbps

Latency - 17 ms

Thank you so much for your assistance with this. 

Kudos0

Re: I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

The issue would appear to be something other than your speed.  Is the issue that certain webpages do not load quickly?  Who is your ISP?

Kudos0

Re: I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

Hello,

All my webpages load slowly, that is my concern. The fact that I've tried (what I can do within my scope of knowledge) of trying to resolve this issue and the pages all still load slowly. No matter what time of the day or night. My ISP is Verizon. 

Anything you can to help me is greatly appreciated. 

Kudos1 Stats

Re: I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

It looks like setting the router's MTU to 1496 from the default 1500 might be something to try.

http://forums.verizon.com/t5/Fios-Internet/Web-pages-won-t-load-consiste...

Kudos0

Re: I have 75/75 internet speed. I have ran Full System Scan & Norton Power Eraser to remove any viruses pc. Still SO SLOW loading.

This thread is closed from further comment. Please visit the forum to start a new thread.