• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs

Not what you are looking for? Ask the experts!

This forum thread needs a solution.

Identity Safe Quits Working

Using Comcast/Norton version, Identity Safe Toolbar version 2013.4.14.23, updated before upgrading to Firefox 36.0.1. Identity safe quits working after logging in. Click the button to access login, nothing happens. I have to close firefox, then reopen, login works for a short while, then quits again. Very annoying. Identity safe toolbar worked fine before the latest update, is there a fix for this?



Re: Identity Safe Quits Working

Hello Aqua

There is currently a problem with a server on the Norton side of things that is causing some problems with various Norton features currently. Norton is aware of the problem and is working on a solution. It is an intermittent type of problem. It has been ongoing now for a couple of days. This is probably causing your problem now. Please give it a few more days and hopefully it will be fixed by then.

Success always occurs in private and failure in full view. Windows 10 Pro 64 bit Norton Core Security Plus Core Firmware 282 I E 11 Chrome latest version.

Re: Identity Safe Quits Working

It's my understanding that the native version of IDSafe extensions for the Comcast variant (NSS) does not rely on Norton Cloud services - at least not for vault usage...

Just a guess (stab in the dark, really), but worth a quick look would be to check your list of installed Windows Programs (Windows Control Panel / Programs and Features) to see if in addition to NSS, you also have the standalone version of Norton IDSafe installed.  If so - it can conflict with the version that's included in the Comcast NSS and therefore could be the cause of your issue.  Anyway, if it's there in the list, it should be uninstalled.

Yank is sort of our "Forum Expert" on the Comcast NSS - So perhaps he will have something more to add...



Kudos1 Stats

Re: Identity Safe Quits Working

Hi AquaHolicz,

OK, first of all, the server being down has nothing to do with your Norton Security Suite Identity Safe as that product uses a Local Vault which is tied to a Windows User Account instead of the Norton Account.  So the server situation has nothing to do with your problem.

avjohnnie's "stab in the dark" is a possibility, but there is another item I am more concerned about because in order for the Stand Alone ID Safe to be installed, you would have had to attempt an uninstall and the situation I am referring to would have been corrected when you reinstalled.

The current version of NSS is in fact, you said you are using version That is over a full version old (if that was not a typo).  Even if it is in fact, it is still some updates behind.

For starters, please run manual LiveUpdate (rebooting if requested) until LiveUpdate responds with the specific words "no updates found".  Reboot.   At that point in time from the main page of NSS go to Support > About and tell us the version number that appears.

Once we get all the info from that, we can press on forward if more is required.


Re: Identity Safe Quits Working

Hey Yank, Thanks for replying, I know from reading a lot of your posts over at Comcast Forums, you are very knowledgeable on Norton. The reason my version is so far behind is because the new version locks my hosts file, and runs my cpu up to 80% with nothing else running. I had posted about this problem, didn't get a satisfactory answer, so I went back to the old version and shut off auto update to new version.I built this computer myself, as I have built all the other computers I have owned(except for laptops of course), and it's never gave me too many problems. AMD 3ghz black(not overclocked), 8gb ram, 120gb Samsung 840 Pro SSD, 2 Western Digital 500gb ATA (IDE) drives When looking at addons in Firefox, the toolbar version updated correctly to the newest version. Up until this newest update, I had no problems with the identity safe. The buttons just quit responding, the only change in my system being the newest update to be compatible with the Firefox 36. Identity safe will work once or twice, then the toolbar buttons quit responding. Closing Firefox, run CCleaner, then reopen Firefox, and the buttons respond again. I tried dumping my Identity Safe, then re-importing from a backup, no luck. The backup is the same one I've been using for awhile, never had a problem with it. From what I can tell it seems to be a problem tied to the newest toolbar update. By the way, I run live update first thing every day when I start my computer, never had any problems until Comcast went to version 21.xx. If Norton/Comcast has fixed the host file locking on newer versions, then I don't mind updating, but locking it and not leaving me an option to shut that feature off is unacceptable to me. Thanks for your help, AquaHolicz

This thread is closed from further comment. Please visit the forum to start a new thread.