• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

Log in problem

I have had to download Norton 360 a total of three times on my new computer due to problems outside of Norton. I have Norton on two other computers also under a three device licence.  However on two of the successful downloads  on this computer clicking "log in"  in Norton Community directed me to a page telling me that there was a problem and to try again. This was every time I reached it from the help section in the Norton desktop display window.  However I discovered that if I used the "sign up" box next to "log in" it worked as if I had signed in normally.  I also found that if I approached Norton Community from Google on Edge "log in" worked as it should. I wonder if downloading Norton 360 so many times has thrown it out of kilter because I did get warnings telling me variously to the effect that my trial version would expire in a day or that it had expired and to renew. However my account tells me all is in order and my three licences are good until renewal next year. I can obviously still use Norton Community but if any person knows a simple way to correct it I would be pleased to hear it.     

Replies

Kudos0

Re: Log in problem

I've been checking this out and now don't consider it a serious matter although there does seem to be glitch with the small "log in" next to "sign up" as mentioned -"sign up" gets me in as log in ( no new account).  In addition the purple coloured large "login" button on the opening page works fine and approaching with Internet Explorer 11 and Edge all let the small "log in" work normally  As the small "log in" button didn't work when approached from "help" in the desktop Norton window on two downloads of Norton 360 as described above I wonder if it is Norton's end.     

Kudos0

Re: Log in problem

Further info - I have XP on Norton maintenance mode and  Windows 7  and Windows 10 both on Norton 360.   All have the same glitch as above re the small "log in" button on Norton Community opening page.  I don't know if this is common to all or just me.

This thread is closed from further comment. Please visit the forum to start a new thread.