• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

NIS Bug

Reproducible on 2 machines W7 x64 and NIS 21.4

Just went yesterday on Adobe's website to update Flash Player and NIS popped a message that "there is no available reputation information about that file", very strange as after 24+ hours of FP release there would be millions of users downloaded the file.

I allowed the installation and went to Security History, both via the Advanced NIS GUI or via "standalone" mode through Taskbar NIS icon.

The file was listed in History BUT when I clicked on the "More details" link the Security History window became unreponsive.

Everybody knows that nis.exe cannot be killed in taskmgr so the solution was to reboot the pc.

Upon reboot, same behavior so rebooted again.

Please note that this event is not recorded in Windows Event Viewer and while rebooting I got a message, (while Windows were shutting down), similar to this: (do not remember the exact codes but the message structure was the same).

Please investigate and fix...

It appears that this issue is present with files having No Available Reputation info because for all other files listed in Security History all info links work correctly.

It does not seem to affect the functionality of NIS after reboot. (NIS product corruption etc).

Thanks.

Replies

Kudos0

Re: NIS Bug

Reproducible on 2 machines W7 x64 and NIS 21.4

Just went yesterday on Adobe's website to update Flash Player and NIS popped a message that "there is no available reputation information about that file", very strange as after 24+ hours of FP release there would be millions of users downloaded the file.

I allowed the installation and went to Security History, both via the Advanced NIS GUI or via "standalone" mode through Taskbar NIS icon.

The file was listed in History BUT when I clicked on the "More details" link the Security History window became unreponsive.

Everybody knows that nis.exe cannot be killed in taskmgr so the solution was to reboot the pc.

Upon reboot, same behavior so rebooted again.

Please note that this event is not recorded in Windows Event Viewer and while rebooting I got a message, (while Windows were shutting down), similar to this: (do not remember the exact codes but the message structure was the same).

Please investigate and fix...

It appears that this issue is present with files having No Available Reputation info because for all other files listed in Security History all info links work correctly.

It does not seem to affect the functionality of NIS after reboot. (NIS product corruption etc).

Thanks.

Kudos0

Re: NIS Bug

Hi Apostolos,

I updated FP v 14.0.0.145 today on Windows 7 32bit with NIS 21.4

FP has been updated correctly and the NIS History shows hundreds of thousands of users have downloaded this file.

Maybe someone who is using Windows 7 64bit could say more.

Regards,

Sandro

Sandro
Kudos0

Re: NIS Bug

Hi Sandro,

It has nothing to do with OS it has to do with NIS version and also if at the moment when I tried to update FP the Symantec server to which my NIS connects was updated or not.

Before updating FP I made sure that the Norton Insight idle task had ran in order for the db to be current but no, no joy.

Also, did you updated like I did, which means go to Adobe's website and running the online installer through IE 11 or did you use an offline FP installer?

This is the first time I had this issue.

Regards,

Kudos0

Re: NIS Bug

" It has nothing to do with OS it has to do with NIS version and also if at the moment when I tried to update FP the Symantec server to which my NIS connects was updated or not.

Before updating FP I made sure that the Norton Insight idle task had ran in order for the db to be current but no, no joy. "

I just wanted to say that I have not had the problem you described.

" Also, did you updated like I did, which means go to Adobe's website and running the online installer through IE 11 or did you use an offline FP installer? "

YES, I updated FP online through IE 11 from the Adobe website.

Sandro
Kudos0

Re: NIS Bug

Hi Sandro,

See screenshot:

I cannot click on the link "More Details" because the Security History window becomes unresponsive (hangs).

Kudos0

Re: NIS Bug

Hi Apostolos,

The picture you posted is not yet visible. In the meantime, I'm trying to reproduce the issue with other "new files"

If I can get something like that, I'll be here to update the thread.

Sandro

Sandro
Kudos0

Re: NIS Bug

" The picture you posted is not yet visible. In the meantime, I'm trying to reproduce the issue with other "new files""

Hi Sandro,

Thank you for testing, be sure that the files you test have a Norton Reputation status of "Unproven".

Best regards,

Kudos0

Re: NIS Bug


Apostolos wrote:

Thank you for testing, be sure that the files you test have a Norton Reputation status of "Unproven".


Hi Apostolos:

I can't find any files in my Download Insight history with a status of Unproven, but other users, especially those in the UK, have reported recent problems with File Insight -  see today's post here from Symantec employee Lucky Sondhi.  If your computer is unable to connect to the backend Symantec servers to check the trust ratings of your downloaded files this might be the underlying cause of your problems.

-------------
MS Windows 32-bit Vista Home Premium SP2 * Firefox 30.0 * IE 9.0 * NIS 2013 v. 20.5.0.28
HP Pavilion dv6835ca, Intel Core2Duo CPU T5550 @ 1.83 GHz, 3.0 GB RAM, NVIDIA GeForce 8400M GS

Kudos0

Re: NIS Bug

Hi Apostolos,

I also don't have any files in History with a status of Unproven.
I also uninstalled and reinstalled FP without having encountered similar problems.
AS Imacri says, maybe you've had problems like those shown in the link.

Regards,

Sandro

Sandro
Kudos0

Re: NIS Bug

" I can't find any files in my Download Insight history with a status of Unproven, but other users, especially those in the UK, have reported recent problems with File Insight"

Hi Lori,

Thank you for your reply, I'm already aware of the issues you described, however my Norton Insight GUI link and the Norton Insight idle background task have no problem running each day with a status of "Completed".

I do not know if despite the fact that the idle tasks complete each day if they are getting the latest database or not or even if the received db is current.

If you notice, I downloaded and installed FP more than 24 hours after it's release.

Regards,

Kudos0

Re: NIS Bug

Just a quick note to say that my real problem is not the File insight glitch but the fact that NIS becomes unresponsive when I click on the "More details" link in Security History when a file has a status of Unproven.

What would happened if, instead of FP download, I would decide to download a Virus, NIS would crash and after this what??

The Virus would have a nice party in my system...

It raises concerns... at least...

Regards,

Kudos1 Stats

Re: NIS Bug

I agree Apostolos,

Maybe something went wrong during the upgrade.
If you agree, you could always use NRnR to see if the problem still persists.
Just a thought.

Regards,
Sandro

Sandro
Kudos0

Re: NIS Bug


Apostolos wrote:

If you notice, I downloaded and installed FP more than 24 hours after it's release.


Hi Apostolos:

All I can report is that, like Sandro_cm, I had no problem downloading and installing the latest Adobe Flash v. 14.0.0.145.  I uninstalled the old Flash v. 14.0.0.125 from my Control Panel, did an extra wipe with the Flash Uninstaller for Windows, and installed the latest Flash using the install_flash_player_14_plugin.exe installer downloaded from http://www.adobe.com/products/flashplayer/distribution3.html.  This offline installer was downloaded at  8:00 PM on 08-Jul-2014, which was within 24 hours of the official release date of 08-Jul-2014.

If your File Insight was working correctly at the time of your download, then the most likely reason for an Unproven status for your installer would be that the file was corrupted during download, resulting in an altered SHA256 hash that File Insight could not confirm as valid.

-------------
MS Windows 32-bit Vista Home Premium SP2 * Firefox 30.0 * IE 9.0 * NIS 2013 v. 20.5.0.28
HP Pavilion dv6835ca, Intel Core2Duo CPU T5550 @ 1.83 GHz, 3.0 GB RAM, NVIDIA GeForce 8400M GS

Kudos0

Re: NIS Bug

"

If your File Insight was working correctly at the time of your download, then the most likely reason for an Unproven status for your installer would be that the file was corrupted during download, resulting in an altered SHA256 hash that File Insight could not confirm as valid."

Hmmm.. same behavior on 2 systems and also after uninstalled and reinstalled FP??

I finally gave up with Insight and used an offline installer with no issues.

Again, it's not normal than NIS crashes/hangs even if a corrupted download was delivered right??

Regards,

Kudos0

Re: NIS Bug


Apostolos wrote:

Again, it's not normal than NIS crashes/hangs even if a corrupted download was delivered right??


I don't think a NIS crash/hang is "normal" in any circumstances, but if NIS is trying to re-check the reputation of the "Unproven" installer when you open the file's Download Insight report from your security history, then the current issue with disconnects with the backend File Insight servers described here might cause your NIS installation to hang.

If you don't believe that your crashes are related to this temporary connection problem with the File Insight server then I'd suggest you run the Norton Remove and Reinstall (NRnR) tool as Sandro_cm suggested just in case your NIS installation is corrupted.

-------------
MS Windows 32-bit Vista Home Premium SP2 * Firefox 30.0 * IE 9.0 * NIS 2013 v. 20.5.0.28
HP Pavilion dv6835ca, Intel Core2Duo CPU T5550 @ 1.83 GHz, 3.0 GB RAM, NVIDIA GeForce 8400M GS

Kudos0

Re: NIS Bug

"

I'd suggest you run the Norton Remove and Reinstall (NRnR) tool as Sandro_cm suggested just in case your NIS installation is corrupted."

I have already done it, the first date when the issue occured, only on one of my systems, so I can test with the other.

Results: On the first system with NIS uninstalled/reinstalled the issue was still there, on the second one, NIS is still working properly, all the tasks and functions are operational, but issue was still there, therefore my previous remark that "it does not seem to affect NIS functionality".,and even now NIS is working.

Let me know if you need any extra info.

Cheers,

This thread is closed from further comment. Please visit the forum to start a new thread.