• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos3 Stats

NIS V 21.0.1.3 aka 2014 experience so far !

I've had the new version on both my machines for two days now, and I have to say it's all working flawlessly. The install and operation, has been trouble free. Looks like Norton got it right this time, at least for me ! This is how v 20 should have been !

Windows 10 Home X 64

Replies

Kudos0

Re: NIS V 21.0.1.3 aka 2014 experience so far !

I've had the new version on both my machines for two days now, and I have to say it's all working flawlessly. The install and operation, has been trouble free. Looks like Norton got it right this time, at least for me ! This is how v 20 should have been !

Windows 10 Home X 64
Kudos3 Stats

Re: NIS V 21.0.1.3 aka 2014 experience so far !

It's always good to read positive feedback for a change. 

I'll add my voice here and say Norton 360 v21 is also working well, only small glitches with the new vault.

Norton 360 seems to use less system resources as well. 

A little bit of knowledge is... well a little bit of knowledge.
Kudos2 Stats

Re: NIS V 21.0.1.3 aka 2014 experience so far !

Same here. Far superior version out of the gate then what that mess was with v20. Windows 7 Home SP1 64 bit and Windows 8 Pro 64 bit.

Kudos0

Re: NIS V 21.0.1.3 aka 2014 experience so far !

Credit where it's due, Krusty !   I'm often among the first to criticise Norton, when they screw up so it's only fair to give kudos, where deserved !.... Btw, the download size via the Check for new Version tab, was about 306 mb !

Windows 10 Home X 64
Kudos0

Re: NIS V 21.0.1.3 aka 2014 experience so far !

Sadly NAV 2014 - resurrects earlier problem - Blocks Ports 25/110 - Useless with POP3 email such as Windows Live Mail. 

Had Norton Tech state that Live Mail is only partially supported - news to me!

Having only just upgraded from NAV 2013 - was happy and all working - bit of a blow to have to disable email protection just to get email.  Hopefully a bug fix is in the pipeline

Kudos1 Stats

Re: NIS V 21.0.1.3 aka 2014 experience so far !

Installed it two days ago on my Win8 machine, without a glitch and running well. Upgrade took, without reboot, only 5 minutes, including download.

Booting with 'agressive' setting seems to be really faster, even from SSD and overall processing is smooth.

Memory, especially of the user-task is much lower (from 80MB before to 20MB now).

Regards, Hugo

W10 1809 and 1903 / W10 Insider / IE11 and FF 67, TB 60.7, NS 22.17, (Android 7 with NMS)
Kudos0

Re: NIS V 21.0.1.3 aka 2014 experience so far !

I have no problem with POP3 on ports 25/110 at all, but working with Thunderbird.

Most of my email addresses are on 25/110.

Do you have problems with specific mail servers or with all?

Regards, Hugo

W10 1809 and 1903 / W10 Insider / IE11 and FF 67, TB 60.7, NS 22.17, (Android 7 with NMS)
Kudos0

Re: NIS V 21.0.1.3 aka 2014 experience so far !

gpfcomp    I'm using Windows Live Mail, and have had no problems accessing my mail...What O/S are you using ?

Windows 10 Home X 64
Kudos0

Re: NIS V 21.0.1.3 aka 2014 experience so far !


F4E wrote:

gpfcomp    I'm using Windows Live Mail, and have had no problems accessing my mail...What O/S are you using ?


I use Windows Live Mail exclusively and haven't had any problems at all either.

A little bit of knowledge is... well a little bit of knowledge.
Accepted Solution
Kudos1 Stats

Re: NIS V 21.0.1.3 aka 2014 experience so far !


gpfcomp wrote:

Sadly NAV 2014 - resurrects earlier problem - Blocks Ports 25/110 - Useless with POP3 email such as Windows Live Mail. 



Hi gpfcomp:

Select your e-mail program from the list here and try the recommended SMTP/POP port settings or use the generic settings of SMTP port 25 (or 587 if you have difficulties sending mail) and POP port 995.

I use Windows Mail on my laptop and had to set my ports to 587/995 in order to send/receive messages from my Windows Live account when my laptop is connected to public WiFi.

------------
MS Windows Vista Home Premium 32-bit SP2 * Firefox 23.0.1 * IE 9.0 * NIS 2013 v. 20.4.0.40
HP Pavilion dv6835ca, Intel Core2Duo CPU T5550 @ 1.83 GHz, 3.0 GB RAM, NVIDIA GeForce 8400M GS

This thread is closed from further comment. Please visit the forum to start a new thread.