This forum thread needs a solution.

Norton 360 on Windows 11 with Parallels 17 and Macbook M1 not installing


With Windows 11 in full production and subsequently Parallels supporting Mac M1 silicon for a while now, I still get an error installing Norton 360 on my Windows 11 virtual image using the latest installation Norton setup file. Does anyone know if it works (my platform versions below) or is still unsupported? 

The N360Downloader.exe initialise, installing message appears, prompts the Windows UAC,  start downloading the 277MB file, and then boom, "An error has occurred" with link (which provides me just access to the support search page). (Screenshot). 

I have the Parallels version latest 17.1.2 (build 51548) and the Virtual instance of Windows 11 is Windows 11 Home 21H2 build 22000.593, running Parallels on a Mac M1 2020 with macOS Monterey 12.3. Windows 11 is up to date

Appreciate any feedback,

File Attachment: 



Re: Norton 360 on Windows 11 with Parallels 17 and Macbook M1 not installing

I have asked this be moved to the Mac board where more Mac users will see it.


Re: Norton 360 on Windows 11 with Parallels 17 and Macbook M1 not installing

Hello. Some good information is over here in this thread on the Mac forums board. Officially Norton is supported on the M1 architecture and Monterey 12.x per this KB article.  Does coherence mode work ok on your side? Is the Windows 11 VM instance under an account with admin rights? I'm not an MAC user but thought I'd add some thoughts to help all the same.


MS Certified Professional / Windows 11 Home 22H2 x 64 build 22621.1265 - Windows 10 Pro x 64 version 22H2 / build 19045.2788 / Norton Security Ultra - Norton 360 Deluxe ver. / Opera GX LVL4 (core: 96.0.4693.104) 64 bit-Early Access w/Norton Chrome Extensions

Re: Norton 360 on Windows 11 with Parallels 17 and Macbook M1 not installing

Hi SA, 

Thanks for the link but I have read it to the end prior to submitting my post. Unfortunately, the thread ends prior to the production release of Windows 11; which I use on the VM. Norton on the Mac host platform works just fine. It's the VM installation of Norton360 Windows edition that just gets just past downloading the 277MB and as it starts installing just stops with a nondescript error dialog with a support link as described earlier.

The VM is a fresh installed Windows 11 VM with the latest patches, and the second build I tried. No other blocking software or A.V running on it.

This happens on the office and home networks. I have zero connectivity issues from both the VM and the host (wired and wireless). 

I tried installing it in coherence mode as well as in full mode. UAC is enabled and the VM account is under the admin group. The VM is not domain-joined/AD integrated) and I make use of a Microsoft account login. I've tried running the installer in administrator mode and in compatibility mode which starts at Win8 and obviously a dead end. 

I've switched to local account login

I have also changed the Parallels virtual NIC from NAT (Shared Network mode) to Bridged (direct). 

I've refreshed Windows Defender and even bypassed it, including refreshing the Windows local firewall, setup an any-to-any only policy

Running out of options. Going to be a pity to pay for another A.V package while I still have spare licenses to use on my subscription. :-/


This thread is closed from further comment. Please visit the forum to start a new thread.