• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos1 Stats

Question about norton quick menu

Hi,

I have a question regarding norton quick menu (Norton 11.1.2(17) for mac).

Shouldn't I see Live update sitting in there along with NAV?

All is running fine except the fact that live update is running in silent mode (in the past It was open after updating until I ask it to quit).

Is there anyway (other than reinstalling NAV) to have this functionality back and see LU back in the quick menu?

Thx in advance for your help!

Replies

Kudos0

Re: Question about norton quick menu

I'm not sure what would cause this symptom, apparently the LiveUpdate QuickMenu plugin is not loading.  I assume you have tried restarting your machine; short of reinstalling, we'll need to get some more information, if you can do the following:

1. Download GatherSymantecInfo.zip from:
ftp://ftp.symantec.com/misc/tools/mactools/GatherSymantecInfo.zip
2. Expand GatherSymantecInfo.zip using Apple’s archive utility (other programs may not expand with proper permissions):
/System/Library/CoreServices/BOMArchiveHelper (OS 10.4)
/System/Library/CoreServices/Archive Utility (OS 10.5/10.6)
3. In GatherSymantecInfo folder, double-click GatherSymantecInfo.command.
4. When prompted, enter your computer user password.
5. When prompted for a subscription key, simply press return.
6. Attach the generated SymantecInfo.txt file to your reply.

If you prefer not to post the info publicly here, let me know and I'll give you an email address where you can send it.

Kudos0

Re: Question about norton quick menu

Hi Lee_G and thank you for your answer.

I've finally found a way to have it back reinstalling LU.

What is a bit strange to me is the fact I have to install LU twice.

Once to be able to have the correct NAV version workink with SL and once more to have the options within Quick Menu.

It looks like the components did not register properly in the first place (but all features were working as expected).

At that point I am wondering (for my personal knowledge) if there can be any file where those two components should have been registered (like some sort of .ini file) as they just, apparently, "didn't show up" in quick menu.

Kudos0

Re: Question about norton quick menu

Without speaking in too much detail, there isn't really a registration file per se.  The menu is populated by checking for plugins within a particular folder, and plugins have to be verified before they load.  It sounds like either the LU plugin was not present or could not be verified.  Either way, I can't see why the normal installation didn't work initially.

I'm not sure if I was reading something into your initial post, but was LU in the QuickMenu at some point in the past, and disappeared recently?  If so, was there any other change you can correlate to the disappearance?

Kudos0

Re: Question about norton quick menu

To make a long story short, I had to reinstall my computer with SL 10.6.7 and my Norton installation disk is pretty old now so I've installed it then installed LU 5.1.2 to get the latest version.

The only missing part was LU and Scheduler in QM but installing LU 5.1.2 again put the files in the correct location apparently (even thow i've tried to copy the 2 plugins found in /Library/Application Support/Norton Solutions Support/Scheduler/PlugIns into /Library/Application Support/Symantec/SymQuickMenu but with no luck).

Kudos0

Re: Question about norton quick menu

The Scheduler plugins are not QuickMenu plugins, so it isn't surprising that didn't work.   What was the version of NAV you had the on the original disk?

Kudos0

Re: Question about norton quick menu

Quite an old one !

11.0r91

Kudos0

Re: Question about norton quick menu

OK, thanks.  Knowing the version may be useful if we want to try reproducing the issue, though since a second install fixed the problem, that may be enough of a workaround.   Hopefully this is an unusual situation, but if other people are encountering it, we may need to look into it more deeply.

Kudos0

Re: Question about norton quick menu

Fine with me.

Would you mind to tell me the name of those two plugins and where they should be located?

Not that I plan to have to install my machine again in the near future but I am a bit curious!

Kudos0

Re: Question about norton quick menu

Sure, in fact there are three:

APQuickMenu.plugin

LiveUpdateQM.plugin

QuickMenuManager.plugIn

All three should be in /Library/Application Support/Symantec/SymQuickMenu

It's possible the file (actually a bundle) was there but somehow malformed before the second install.

Accepted Solution
Kudos0

Re: Question about norton quick menu

As far as I remember, the only missing one was the LiveUpdateQM.plugin (that's why I tried to copy the ScheduledScannerPlugin.plugin and LiveUpdateSchedPlugIn.plugin in the first place.

I would guess the entire folder (/Library/Application Support/Symantec/SymQuickMenu) gets overwritten during the upgrade from 11.0 to 11.1.2.

But as said, as everything is back to normal...

Once again, thank you Lee_G for your help.

This thread is closed from further comment. Please visit the forum to start a new thread.