• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

[Sharing] Norton WiFi Privacy connected. long time to resolve host

if your browser stuck at resolving host for few second every time you typed in an address. try following method.

https://www.privateinternetaccess.com/forum/discussion/23759/windows-10-creators-update-slow-to-resolve-host

two steps:

1. Disable IPv6
Control Panel\Network and Internet\Network Connections > select 'Properties' of your network interface (not TAP adapter) > uncheck IPv6 > then apply

2. Next, disable SmartNameResolution in registry

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient] > look for 'DisableSmartNameResolution' > if it does not exist then create it by right clicking in right pane and selecting new DWord and name it DisableSmartNameResolution then change its value to 1. 

If you prefer you can use the below link to download a .zip file with the reg file in it which will create it for you > http://www32.zippyshare.com/v/OaxlWfvC/file.html > Unzip the file and merge it into the registry. Or... you can manually create a .reg file yourself using Windows notepad, to do so open up a new text document and paste the below into it and save it as DisableSmartNameResolution.reg (so you will have it for future use 'cause Windows 10 updates may remove or change the registry entry after the update, so after an update reapply).
 

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient]
"DisableSmartNameResolution"=dword:00000001

after the above steps, reboot the computer. (actually you don't need to reboot but some people might need to do so for some reason and its a pretty standard thing to reboot after registry changes especially on 32 bit systems, your choice.) The whole thing can be done in two minutes or less, its simple to do.

If using Windows 10 Pro and above you can also disable Smart Name Resolution via the group policy editor (gpedit.msc), to do this:

1. Press WIN+R and write gpedit.msc 
2. Expand Administrative templates 
3. Expand Network 
4. Click DNS-client 
5. Double-click "Turn off smart multi-homed name resolution" 
6. Check the box called "Enabled" 
7. Click "Apply all" and then "OK"

basically, what is happening is; The Windows 10 Creators Update is waiting for timeouts from trying to resolve any IPv6 addresses via the other network interfaces and for Smart Name Resolution (which determines which adapter returns the quickest DNS response). This leads to slower browsing because its checking the other network interface (if IPv6 is enabled on the interface) in your system first and the timeout for that is up to about 60 seconds then it waits for Smart Name Resolution to time out before going with the TAP adapter interface. Disabling IPv6 on the interface and disabling Smart Name Resolution in the registry keeps them from being checked thus no timeout wait and thus faster browsing.   

Just a little note, PIA is not the only VPN service experiencing this issue with the Creators Update. In addition this issue is also present on OpenVPN 2.4 with directive block-outside-dns.

note: Windows 10 gives top propriety to actual physical hardware interfaces first so they are the first checked. The TAP adapter is a software interface which mimics a hardware interface and thus has the lowest priority.