• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

Smart firewall blocking communication between apps

Hi

Smart firewall is blocking connection between Visual Studio 2017 cross platform connection and Hyper-V Linux Server. And blocking internet connections of Hyper-V Linux Server too. I need to turn off to test my C++ cross platform applications. How can I configure (program control / traffic rules) to avoid this behavior?

Thanks in advance

Replies

Kudos0

Re: Smart firewall blocking communication between apps

I really have no idea other than to check your firewall settings? and see if your networks are categorized properly. A matter of public, private, or trusted for each network. Otherwise I'm at a lost since I don't do networking issues as much as others. Sorry

DELL XPS 8900 / I7-6700 / 64bit / 16GB RAM Win7 Pro - Norton Security
Kudos0

Re: Smart firewall blocking communication between apps

Hi

I'm asking exactly this. How to configure Smart Firewall and/or my network definitions to avoid this behavior?

Norton is installed on my home computer, and I have only one wired network, defined as private.

Thanks for your help

Kudos0

Re: Smart firewall blocking communication between apps

If turning off the Norton Smart Firewall resolves your connection issues, try resetting the Firewall.   

To reset the Norton firewall, from the main Norton Security screen click on Settings - Firewall. On the General tab, click on Reset beside Firewall Reset. Restart your computer. As you use programs that access your network/internet, the firewall rules will be created again.

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: Smart firewall blocking communication between apps

This solution doesn't work. Hyper-V guest doesn't have internet access yet, and Visual Studio 2017 cannot connect with Hyper-V guest. I believe that firewall rules needs to be created manually, but I don't know how to do that.

This thread is closed from further comment. Please visit the forum to start a new thread.