• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

When Wi-Fi privacy is turned on i get Russian Google search

When Wi-Fi privacy is turned on elements of Google search are in Russian...I have also noticed Russian ads on websites...It just started doing this a couple of days ago...I have the proxy set to USA and i have checked to see that indeed the proxy is listing a US city...Am i doing something wrong?

Replies

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

What country are you actually located in? 

What browser are you using? Do you see the same behavior in another browser? 

Try clearing your browser's cache and history.

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

I'm in the USA...I've had this problem with both 64 bit and 32 bit Firefox on Windows 10...I've cleaned cache and history (first thing i did)...Uninstalled and reinstalled Firefox multiple times...ran Firefox with and without add-ons...

I have noticed today that when on the New York proxy i got the Russian stuff...Now i'm on the Dallas proxy all is normal on both 32 and 64 bit Firefox...Haven't tried on IE yet...but may later today.

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

Since that post i have tried San Jose and Chantilly proxies...They were OK...Got on New York proxy again and the problem was back.

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

Problem appears on Internet Explorer 11 while on NY proxy...I cleared cache and tried IE 11 on Chantilly proxy and all was well...I don't know how many US proxies Norton runs...but at least from my point of view the problem seems to appear only when i'm on the New York proxy.

Kudos1 Stats

Re: When Wi-Fi privacy is turned on i get Russian Google search

That is an interesting find. I'll pass it along to my Norton contacts to see if they have any insight on this.

Thanks for your diagnostic work.

EDIT

I just tried the NY servers and see the same as you. I have notified Norton.

Things happen. Export/Backup your Norton Password Manager data.
Kudos1 Stats

Re: When Wi-Fi privacy is turned on i get Russian Google search

Hi @13db,

Thank you for reporting this issue. 

I've passed it on to the Norton WiFi Privacy team for investigation.

I'll get back to you when I hear back.

Thank you @peterweb 

Mohanakrishnan G | Norton Forums Administrator | Symantec Corporation
Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

I'm having the same problem.  Located in the SE USA and using Chrome.  Does the same with IE when I start Google Gmail or Browser. Will wait for the solution.....

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

So what's the status?

I am thinking of buying this product to epecially enhance security for online banking transactions....but if your third party provider has been hacked or does deals with Russians, or any other hackers, then you can kiss my....business goodbye! 

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

I had the same issue. I use Chrome, and I set my home page to https://www.google.com/ncr. Problem solved. 

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

It's one thing if Google thinks I'm in Ukraine.  If my data is flowing through another country without my consent, I consider that an unacceptable security risk.

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

With this problem we are seeing, our data is being sent through NWP to servers in USA. It is just the when you pull up Google pages that you are getting the Ukranian Google page. 

@Mohan_G

Is there any update on this serious problem?

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

After you connect to USA server, can please check your IP with "what's my ip" . If  "what's my ip" correctly shows USA then the issue is with google. 

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

This happened for the first time to me today as well. I did a trace-route to see why it thinks I am in Ukraine, if that helps.

1. Local IP

2. 142.0.201.169 (Dallas, TX)

3. se-us01-s1.servers.com [173.0.144.60] (Dallas, TX)

4. 173.0.144.252 (dallas, TX)

5. dls-b22-link.telia.net [62.115.146.34] (forest reserve in germany....)

6. dls-b21-link.telia.net [62.115.137.60] (forest reserve in germany....)

7. google-ic-324802-dls-b21.c.telia.net [62.115.154.223] (forest reserve in germany....)

8. 108.170.240.193 (mountain view california)

9. 216.239.42.135 (mountain view california)

10. 172.217.9.142 (google.com)

Here is the same route with VPN turned off...

216.180.179.93 (Idaho)

66.232.64.154 (Idaho)

108.170.254.98 (mountain view california)

209.85.254.34 (Wichita, Kansas)

72.14.232.62 (mountain view california)

108.170.242.241 (mountain view california)

209.85.248.35 (Wichita, Kansas)

172.217.6.78 (google.com)

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

62.115.146.34

organisation:   ORG-TA45-RIPE
org-name:       Telia Company AB
org-type:       LIR
address:        169 94
address:        Solna
address:        SWEDEN

Company is based there, but must have IPs at an IP data center between Texas and California.

This VPN endpoint hosted by Servers.com, Inc.?

OrgName:        Servers.com, Inc.
OrgId:          SERVE-105
Address:        2777 N. Stemmons Fwy
Address:        Suite 1655
City:           Dallas
StateProv:      TX
PostalCode:     75207
Country:        US
Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

I am having the same issues.  when I manually connect to the US Region it works but any reboots or re-starts the system forgets my manual settings and go back to the Ukraine 

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

            [Note: 'Wifi Privacy VPN Connecting To Ukrainian Google' merged into existing discussion by Admin]

Norton WiFi Privacy VPN often takes me to the Ukrainian Google site when I go to www.google.com.  It defaults to www.google.com.ua.  I know it is not a virus on my computer, because disabling Norton WiFi privacy solves the problem 100% of the time.  Sometimes if I log off Norton and then log back on, I go to the US Google site. 

Can anyone explain why Norton is taking me to the Ukrainian Google site when it shows I am in Dallas, New York, or another location in the US?  I'm ready to give up on Norton WiFi Privacy.

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

It only happens to me when I use the Dallas server as far as I can tell, so I guess the work around if we are worried about it is to switch servers.

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

I used to notice the problem only with the New York proxy.  Now it appears with the Dallas one.  It seems very suspicious that Norton Wifi Privacy is sending things to Ukrainian websites.  It makes me wonder if something has been compromised on Norton's end.  I have proved that the problem is with Norton, because it stops 100% of the time when I turn off Norton Wifi Privacy.

Kudos0

Re: When Wi-Fi privacy is turned on i get Russian Google search

skyguy:

I used to notice the problem only with the New York proxy.  Now it appears with the Dallas one.  It seems very suspicious that Norton Wifi Privacy is sending things to Ukrainian websites.  It makes me wonder if something has been compromised on Norton's end.  I have proved that the problem is with Norton, because it stops 100% of the time when I turn off Norton Wifi Privacy.

It appears that google is mis-detecting the VPN endpoint's IP geo-location. Having incorrectly guessed your location it gives you that country's main google page. I don't have a way to get much more details than that.

This thread is closed from further comment. Please visit the forum to start a new thread.