• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

Kudos0

Windows 10 IIS FTP server blocked

Hi

I am at a loss. This was all working fine but recent updates from Microsoft deactivated IIS ! So, I set up my FTP server from scratch again and tested it from a remote connection (using Filezilla client). I get as far as logging in, but it will not allow me to display the target directory when the Norton Smart Firewall is on. If I switch off Smart Firewall, I can access the directory.
I can access the directory from within my LAN with Smart Firewall on.

I have tried adding rules to allow ports 20 and 21 (in and out bound) and also for the range of data ports I specified in IIS firewall.

In the security history, I get entries that state "Unauthorized access blocked (Open Process Token). The "actor" is c:\windows\explorer.exe. From this, I suppose that it is the remote FTP client trying to open the directory.

I am using Norton Internet Security Online (ver 22.7.1.32) on Windows 10.

Does anyone know what I have to configure to get this working?

Thanks in advance

Replies

Accepted Solution
Kudos1 Stats

Re: Windows 10 IIS FTP server blocked

Instead of trying to fix the firewall your self, try just resetting the firewall and let it configure itself.

Go to Settings - Firewall and click on Reset beside Firewall Reset. Then try to connect again.


progre

Things happen. Export/Backup your Norton Password Manager data.
Kudos0

Re: Windows 10 IIS FTP server blocked

Thanks. Worked a treat.

So simple as well!

Kudos0

Re: Windows 10 IIS FTP server blocked

Good to know.

It is called a Smart Firewall. Unless you have really complicated networking needs, it is smart enough to set thing up on its own.

Things happen. Export/Backup your Norton Password Manager data.

This thread is closed from further comment. Please visit the forum to start a new thread.