• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs
Advanced

Not what you are looking for? Ask the experts!

This forum thread needs a solution.
Kudos0

Norton Ghost 15 install and uninstall error

ERROR: Failed to have success running InstallVSSProvider function in MSIInstallVSSProvider Function.

This takes place when installing Ghost 15. I have tried norton removal tool, registry cleanup, and manually hunting down symantec folders. No luck. Ialso get an UnInstallVSSProvider error when uninstalling Ghost 15. The program itself works fine but I'm concerned about some obscure component not working and sooner or later bringing down the whole program. What is this error all about and wheredo I go looking for issues?

Replies

Kudos2 Stats

Re: Norton Ghost 15 install and uninstall error

Hi Searinox,

I would suggest to follow the steps provided in the document below:

http://www.symantec.com/norton/support/kb/web_view.jsp?wv_type=public_web&docurl=20090518143146EN

Although the document is for Norton Ghost 14.0, steps should work for Norton Ghost 15.0 as well.

--Vinod

Kudos0

Re: Norton Ghost 15 install and uninstall error

Thank you very much cause I've been looking all over for more documentation on the VSS provider. The command completed silently without any errors. How can I check if the VSS is installed?
Kudos0

Re: Norton Ghost 15 install and uninstall error

Hi Searinox,

To see the VSS Writer services on your computer, do the following:

1. Click Start > Run.

2. Type the following and then click OK:

cmd

3. On the Command Prompt, type the following and press Enter:

vssadmin list writers

-Vinod

Kudos0

Re: Norton Ghost 15 install and uninstall error

I can confirm that these VSS errors occur for me as well during install and uninstall of Norton Ghost v15 on Winows 7 Home Premium.  I encountered them last night.  I will try the information at the link for installing the SymSnap VSS service manually tonight and report back.
Kudos0

Re: Norton Ghost 15 install and uninstall error

Problem solved. Ran the command and checked C:\programdata\symantec\symantec symsnap vss provider\logs and saw a 0x8004E00F error. Googled it and it appeared to be caused by the distributed transaction coordinator service not running. Looked up services.msc and it was set to disabled. I set it to auto and ran the command again then I checked the log and success was reported.
Kudos0

Re: Norton Ghost 15 install and uninstall error

The manual install does not work for me.  I still get errors in the "ProviderInstall.log" file.  Here's the contents of the whole thing, with line breaks reduced:

 ####### Registering Provider #######
 Register Component Name: Symantec SymSnap VSS Provider   Dll Name: SymsnapProviderx64.dll Product: Symantec SymSnap VSS Provider  Thu Nov 26 00:25:29 2009

 ******* Remove Old Entries before creating new , call UnRegister Provider *******
Failed to get provider DLL path 2  Thu Nov 26 00:25:29 2009
Failed to Get ICatalogCollection object for Applications. Error code = 0x80070005  Thu Nov 26 00:25:29 2009

 ******* Now Call Register Provider *******
Failed to Get ICatalogCollection object for Applications. Error code = 0x80070005  Thu Nov 26 00:25:29 2009

I was on the phone last night with a second level tech support rep from Norton.  We did a whole bunch of things, including uninstalling/reinstalling Ghost multiple times.  Nothing resolved the VSS provider problem, and I'm also getting multiple windows during the install which say "No mapping between account names and security IDs was done."  We ended the phone session with the agreement that Symantec will get back to me within one week regarding the status of this issue.

Kudos0

Re: Norton Ghost 15 install and uninstall error

Hi SilvrDrgn,

Are you using 64-bit version of Windows 7? Also, are you installing Norton Ghost from CD or a downloaded version?

--Vinod

Kudos0

Re: Norton Ghost 15 install and uninstall error

Yes, 64-bit version of Windows 7 Home Premium.  Using downloaded Ghost v15.
Kudos0

Re: Norton Ghost 15 install and uninstall error

I don't know if it helps you in any way to know, but 0x80070005 is Access Denied.
Kudos0

Re: Norton Ghost 15 install and uninstall error

Yes, I know about the access denied.  It would be more helpful if the log told me what and why more specifically.
Kudos0

Re: Norton Ghost 15 install and uninstall error

This could be due to problems with security permissions for the user account. Did you try creating a new admin account and installing Norton Ghost in it?

-Vinod

Kudos0

Re: Norton Ghost 15 install and uninstall error

The account I was in was an administrator account.  I suppose I could try creating a new one and installing with that.  Will have to report back.

Kudos0

Re: Norton Ghost 15 install and uninstall error

I'm sorry, to disagree to this Solution.

I get the same Install-Error with "VSSProvider" and tried all mentioned Solutions.

(Running under Windows 7 Home Premium).

Allways getting the same "InstallVSSProvider" Error, and when making a File-Backup under Ghost 15 comes every time with "snapshot Error %1".

I installed and uninstalled several times, under "Admin" Permissions, with all third-Party Services disabled, with manuell register (by the way the name "VssProviderInstall.exe" in the solution for "Vista" is not the same as under "Windows7", that writes "VssProviderInstallx64.exe", but thats a piece of cake !!)

Now I'm trying several days, and nothing changed.

And Symantec has still no solution ??

Why are all those problems only known to the customer and the supplier never heard of it ??

And even the Customer Support didn't hear that problem !!

My last try will be, installing on another PC with Windows 7.

If there will be the same Result, I must start thinking, Symantec acts in bad faith!!

And at last, I will return the software and get my money back !! 

Kudos0

Re: Norton Ghost 15 install and uninstall error

I had forgotten that, yes, I did already try to install Ghost v15 in a different administrator account.  I did that while on the phone with the customer support representative.  It produced the same errors.

He mentioned that this is a known problem to them that they are investigating.  They've gotten multiple reports of it.

Kudos0

Re: Norton Ghost 15 install and uninstall error

SilvrDrgn,

Has this issue been resolved for you? I am also using Win 7 64 bit with Version 15 internet download and having the same problem as you. Tried all of the above without success.

When I tried the manual install of SymSnap VSS Provider I received the error message: 'vssproviderinstall.exe' is not recognized as an internal or external command, operable program or batch file.

When I went to services and tried to start the SymSnapService, I received: Error 1053: The service did not respond to the start or control request in a timely fashion.

I will appreciate any help out there! Suppose I can use Windows Backup for now, but I would rather not. Thanks.

Scott

Kudos0

Re: Norton Ghost 15 install and uninstall error

No, the problem is not resolved on my computer as of yet.  In fact, I worked for quite a long time on the phone last night with another Symantec support representative.  He collected a whole bunch of logs and diagnostic information from my system for futher analysis.  Supposedly they are going to get back to me within a week.

Interesting enough, when I try other software that uses the VSS functionality (like Macrium Reflect), that other software works perfectly fine.  So, this is definitely an issue with Norton Ghost.

BTW, for your issue, instead of using 'vssproviderinstall.exe' you should be using 'vssproviderinstallx64.exe' in your command.  (You're missing the "x64" in it.)

Message Edited by SilvrDrgn on 12-20-2009 09:48 PM
Kudos0

Re: Norton Ghost 15 install and uninstall error

i have been following this with the same problems and have been able to install from a disc under a 'test' user a/c with admin privileges, getting both the VSSInstall failure and the 'no mapping between a/c names and security id's was done'.  using the referenced document i was able to install the VSS feature, but in trying to see "vssadmin list writers' in either 'test' or my user a/c, both receive the error 'you don't have correct permission to run this command.  please run utility from a command window that has elevated administrative privileges'.  both these accounts are so listed.  i imagine this is related to the  'no mapping' msg. does anyone know how to correct this ? securityid problem? thanks.

Kudos0

Re: Norton Ghost 15 install and uninstall error

(continuation) i ran the security configuration tool in the installed ghost program. there were three a/c there:
1.listed as Acct Unknown: a long series of hyphenated number strings beginning with S- in parentheses
2 listed as Administrators, with in parentheses (my a/c name\administrators)
3. listed as Users,  with in parentheses (my a/c name\users)

my User a/c did not have full control permission as the first two did. after i gave it full permission, running vssadmin list writers still gave the error ' you don't have correct permission level etc.'

i removed permissions from the ACCT Unknown but i still got the same error msg running vssadmin from my user a/c.  does anyone know what that a/c is about?

i did run a b/u to an external esata/usb drive, which seemed to work ok.  when i booted from the install/recovery disc it gave me the option to restore to that, so that seems to be ok.

also, the driver validation tool came up with two errors:
1. wan miniport IKW v2
2. 2 micro integrated ms/mspro/xD controller

could that have anything to do with it??!!

happy new year btw, but it'd be happier w/o these hassles!!

Kudos0

Re: Norton Ghost 15 install and uninstall error

well, wrong again (continued). i just noticed that while it seemed to run a full b/u yesterday, when it tried to back up just documents last nite it failed and i get the error snapshot %1 error EBA B0eF1: OS error 2147754774  that seems to be common the forum. what a hassle. i have nis 2010 running, which was installed prior to this ghost problem.  machine is windows7 professional.
Kudos0

Re: Norton Ghost 15 install and uninstall error

Hi

Almost a similar issue is getting discussed in this thead,

-KrisL

Kudos0

Re: Norton Ghost 15 install and uninstall error

Kudos0

Re: Norton Ghost 15 install and uninstall error

Symantec support was supposed to get back to me in a week after my last post.  Well, it's been quite a bit more than a week, and I still have not heard anything from them on this problem.  I am going to contact them myself again tonight.  If I do not get a resolution, I will be requesting a refund and switching to some other disk imaging software.  (Probably Macrium Reflect since I've used it before, it works good even on Windows 7, and the personal edition is free.)
Kudos0

Re: Norton Ghost 15 install and uninstall error

I didn't have a chance to call Symantec yesterday.  Will try to make some time today.
Kudos0

Re: Norton Ghost 15 install and uninstall error

All,

I have sucessfully restored my system after I deleted the partition of the operating system drive.  I booted my ststem with the custom Ghost recovery disk I created and deleted the partition using the partition utility.  I then exited the CD program and tried to boot my system.  This was done to verify that the partition was indeed deleted.  My computer did not boot as expected, so I again booted my system using the custom Ghost recovery CD.  After my computer booted, I used the recovery wizard to restore the image I had saved before deleting the partition, to the hard drive.  It worked perfectly with no errors.  After the process finished, I exited the program, removed the CD, and allowed the computer to boot from the restored drive.  My computer looks and runs as it did before I conducted the backup and restore tests.  I thought you might want to hear some good news.  Please recall that I encountered about 5 errors when I installed Ghost 15.  The errors occurred right before Ghost finished installing.  Obviously, the errors did not effected the operation of the program, at least for what I am using it for.  On a side note, I checked the Ghost Event Log.  Since I installed and started using the software, no errors were recordered in the log.  The latest entry reads "Info 6C8F0427: Norton Ghost service started successfully."  Nothing for "Details:" and "Source: Norton Ghost".  Thanks!

Kudos0

Re: Norton Ghost 15 install and uninstall error

Ugh, I still haven't had a chance to call Symantec back.  Probably won't until Wednesday night.  Will post another update when I get hold of them again.
Kudos0

Re: Norton Ghost 15 install and uninstall error

Hi

Just to say that I am getting the same errors on Win 7 x 64.

I have spent hours on the chat line and getting different technicians who repeat the same thing every time.

As far as I can see the problem is that  It needs to run VssProviderInstallx64.exe.      This can be found in C:\Program Files (x64)\Norton Ghost\Shared\Drivers, but when you try to run it in the Command window in Administrator mode it does not see it as an executable file and won't run.

 

My thoughts are that this file may be corrupt.

 

Looks like they have been looking at this problem for some time, so its about time that they found a solution.

 

Twice they have said they have escalated the case bt never phoned back.

 

Kudos0

Re: Norton Ghost 15 install and uninstall error

I recieve the below e-mail today.  This may be a way to help them resolve this issue.

[REMOVED]

 

 

[edit: Please do not post email content per the Participation Guidelines and Terms of Service.]

Message Edited by shannons on 01-12-2010 01:35 PM
Kudos0

Re: Norton Ghost 15 install and uninstall error

I contacted Symantec support again today requesting a progress report with this problem and gave them my previous session ID.  The support representative researched it, saw that it's escalated to higher support levels.  He said I will get a call back within 24-48 hours.  I also let him know that if there is no progress, I will be requesting a refund.  So, now it's just a wait and see game if I get the call back.

Kudos0

Re: Norton Ghost 15 install and uninstall error

Hi

 

I spent another 6.5hrs on the chat line with yet another Technician who just went over all the same things again.

It was like 'watching paint dry'. 

 

I have been promised a call back from the Engineering Support Team today, but true to form they never rang.

 

I will keep you posted if they solve the issue.

Kudos0

Re: Norton Ghost 15 install and uninstall error

Just to keep things going, I made a new experience.

I build in a new harddrive to my notebook and installed Win7 32-bit.

After that I installed Ghost 15, got an error about the "System and User account".

Bout backup of the whole Disc and File-Backup went well !!

After that I installed my Anti-Virus Program "Kaspersky".

And now its the same "Snapshot Error %1" again !!

I will deinstall the Anti-Virus Program and look for the result. And, in worst case, I will install Win7 again.

Kudos0

Re: Norton Ghost 15 install and uninstall error

RegBarclaN, what results did you have?

Kudos0

Re: Norton Ghost 15 install and uninstall error

Now the result of the second try!

I restored an image of my harddrive, which was made before the Installation of my Anti-Virus Program

Norton Ghost works well, Image and File-Backup, no Problems!

Then I installed the Anti-Virus Program, and Surprise, Norton Ghost is still working well !

But what's the difference ?

I didn't mention, in the first try I used the MS Easy Transfer to transfer the Settings from my old Vista System.

This took all parts, programs and the whole stuff.

In the second try, I only transferred Favourites and Office Settings, nothing else.

Now my guess is, this first Easy Transfer causes the Problem.

My System is now working as desired, and I hope it will stay this way.

Kudos0

Re: Norton Ghost 15 install and uninstall error

I would suggest anyone having problems with Ghost 15 and Windows 7 do a search for the other threads.  Try Snapshot error %1.  You will find that this problem has been going on since Ghost 15 was released.  Don't let the Tech guys take over your computer to mess around.  They are only doing bad.  No help at all and a big waste of time.  Symantec has had at least one image for over 3 weeks right now and say they are waiting for a developer to look at it.  Translation.  THEY HAVE NO IDEA.  Best thing you can do is request a refund until they get it straight.  Enough refunds and they will fix this problem.

Re: "Snapshot error %1"

Jess

Windows 7 (x64)

This thread is closed from further comment. Please visit the forum to start a new thread.