• コミュニティ内すべて
    • コミュニティ内すべて
    • フォーラム
    • 提案
    • ブログ
高度

お探しの情報が見つからない場合、 フォーラムで質問してください。

拍手0

Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

株式会社シマンテックノートン コミュニティ 日本版コミュニティマネージャー 高島

返信

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

お待たせしました。Firefox 4に対応したパッチの配布が開始されました。

詳細はこちらをご覧ください。

【新しい更新 18.6.0.29】ノートン インターネット セキュリティ 2011 / ノートン アンチウイルス 2011

ご不明な点などありましたら、引き続きこちらのフォーラムにご投稿ください。

以下は古い情報です。

このHotfixを適用することにより、 ノートン インターネット セキュリティ 2011のノートン ツールバーはFirefox 4に対応いたします。

 

このHotfixはノートン インターネット セキュリティ 2011が対象です。それ以前のバージョンをお使いの方は、まず最新のバージョンにアップデートをしてください。ノートン アップデートセンターにて無償でアップデートが可能です。アップデートが完了したら、LiveUpdateを実行し、全てのアップデートをインストールしてください。

  ステップ1
  1. Firefox  4をインストールする。
ステップ2

   1. ノートン インターネット セキュリティ 2011のLiveUpdateを実行する。

   2. LiveUpdateが完了したら「Ok」をクリックする。

   3. 再度LiveUpdateを実行し、全てのアップデートがインストール完了するまで繰り返す。


ステップ3
  1. Hotfixのダウンロード(exeファイル)をダウンロードする。
  2. ダウンロードしたKB20100720112959EN.exe実行する。
  3. 画面に従いインストールをし、再起動しhotfixのインストールが完了。

現在この問題はHotfixをダウンロードしインストールすることで解消されます。LiveUpdate経由では提供されていませんので、 Firefox 4をお使いの方はお手数ですがこのHotfixをご利用ください。次回の大きな製品アップデートがある際に LiveUpdateを通じてアップデートファイルに同梱される予定です。


【追記】

技術情報ページが公開されましたので追記します。

Norton Internet Security と Firefox 4.0 の互換性


【追記:5/9】

現在Firefox 4.01に対応するパッチを準備しております。近日中にリリースされる予定です。パッチ配布の際は再度本フォーラムでアナウンスします。ご不便おかけし申し訳ありませんが、もうしばらくお待ちください。

株式会社シマンテックノートン コミュニティ 日本版コミュニティマネージャー 高島
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

※すみません。一つ前の投稿はなぜかメッセージが表示されませんでした。削除をお願いします。

本日 Firefox を 3.6.x から 4.0.1 へアップデートしたところ、ツールバーが使用不可になりました。
そのため、こちらのパッチを適用しようとしたところ、使用許諾すら表示されない状態です。
(exeを叩いても安全性の確認以降無応答)

Windows 7 Ultimate 64bit SP1 / NIS2011 18.5.0.125 LiveUpDateは最新まで実行済み

アメリカの方でも以下のような投稿がありますし、対応中ということでよろしいでしょうか?
http://community.norton.com/t5/Norton-Internet-Security-Norton/Norton-Toolbar-not-compatible-with-FF-4-0-1/td-p/442788
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

TGMさんへ。

2011.4.7に公開されたHotfixはFirefox4.0へ急遽対応された物です。

したがってFF4.01でノートンツールバー5.5は利用出来ません。

FF4.01への対応を待つか、FFをダウングレードすれば利用できますよ。

ノートンサポート様へ。

前回もそうでしたがFF4.01対応のノートンツールバーを公開する際は利用者に知らせる努力をして下さい。

このサイトに来ないと入手出来ない様なお粗末な対応は止めて欲しいです。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

jeimusuさん情報ありがとうございます。

正直なところ、実行されたかもわからない状態だったので、戸惑った次第です。

対応していないなら「対応していません」くらいのメッセージを表示してくれると助かったのですが、

そのくらいは自分で判断しろということでしょうか。

とりあえず、Tonyさんが来週中にパッチをリリースすると言っていますので、それ待ちですね。

http://community.norton.com/t5/Norton-Internet-Security-Norton/Norton-product-compatibility-with-Firefox-Updates/m-p/443808

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

TGMさんへ。

URL確認して来ました、今回の対応は以外と早いですね!

しかしながらFFの更新頻度は結構多く今後も更新する事が予想出来ます、

FFの更新の度にパッチ探しはウンザリですよね、そこで素晴らしいアドオンを見つけたので

試して見て下さい。

http://ryubuntu.blogspot.com/2011/03/add-on-compatibility-reporter-firefox.html

アイコンをクリックでアドンサイトへ飛びます。

ノートンツールバー5.5も動作します。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

無効化されるにはそれなりの理由があります。

jeimusuさんが紹介しているアドオンは、無効のアドオンを有効にするだけであって、必ずしも、全機能を問題なく使えるようにするものではありません。(有効化=全機能を使える、と誤解している人が散見されます。)

有効化することによって、問題が生じる場合もあります。

そういった問題に対処できるのであれば、利用してもいいでしょう。

Windows 10 pro 64bit / Firefox / NIS v.22
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

一時的な解決法としては一つあります。

1、ノートン製品を改変するのオプションをオフにします。

2、C:\ProgramData\Norton\{0C55C096-0F1D-4F28-AAA2-85EF591126E7}\NIS_18.1.0.37\coFFPlgnを開き、その中にあるinstallというファイルをメモ帳で開きます。

3、その中にある

<em:maxVersion>4.0</em:maxVersion>

の4.0を4.0.*と書き換えた後保存して、再起動、もしくはログアウトして再ログインすれば使えるはずです。

4、使えたら、再び改変オプションをオンにすればOKです。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

qiuzhengruさんの方法も同様です。

問題対処できればいいですが、できないようなら、対応を待つのが賢明です。

強制有効化はすべて自己責任です。

Windows 10 pro 64bit / Firefox / NIS v.22
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

palさん

問題なく作動しますよ。(*^_^*)

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

install.rdfの書き換えは既知でしたので、すでに試みていましたが、

ツールバーそのものはFirefox上で有効になるものの、IDセーフの機能は動作していません。

とりあえずアメリカのサイトを監視中です

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

2012のバージョン6のツールバーは書き換えにより問題なく作動します。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

 qiuzhengru さん

情報ありがとうございます。

が、ここで話題にしている製品は 2011 ですので…

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

ええ、わかってます。

ただ、報告したまでです(#^.^#)

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)


qiuzhengru さんは書きました:

palさん

問題なく作動しますよ。(*^_^*)


たまたまです。

将来的に通用する(問題なく動作する)とは限りません。

Windows 10 pro 64bit / Firefox / NIS v.22
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

今までに記載されてる解決策はNortonが提示も推奨もしてない。

適用する人間は自己責任でやってね。という代物なのでご注意を。

あくまで提示者の環境ではうまく行ってるに過ぎないし、提示者の環境でも(気づいていないだけで)小さな不具合は起きているかもしれない。

何が起きても対応できない人ならやらない方が吉と思います。

まぁ小さなバグフィックスや、セキュリティ対策のバージョンアップの度にアドオンが使えなくなるようではちょっと困りもんですがね。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

既に報告があったかもしれませんが、hotfixを適用するとIEでIDセーフが機能しなくなりました。仕方ないので

インターネットセキュリティを再インストール(設定保持)したところ、IDセーフにログインできなくなりました。

ログインパスワードは絶対間違っていない自身があったので、nortonサポートにchat接続しようとしたらつながらず....。

こういったリスクを想定していたので、ディスクバックアップを採取しており、復旧できましたが、このコミュニティに公開された

パッチはシマンテック社としてどの程度評価されているものなのでしょうか。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

英語版のみですが、IE9にもFirefox4にも正式対応するためのアップデートがあったようです。

18.6.0.29 (Liveupdateにて<英語版のみ>)

hotfixはあくまでhotfixですので、十分な検証はなされないのでしょう。

これはマイクロソフトなども同様で、hotfixに対するhotfixが出ることも珍しくありません。

今はローカライズ作業中でしょうか。

日本語版のアップデートを心待ちにしております。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

英語版は正式対応したのですか。日本語版も早く正式対応して欲しいですね。

TGMさんのおっしゃる通り、MSの対応を考えたら、うかつにhotfixは適用すべきではなかったですね。

Firefox4.0/IE8対応が遅れていたので、IDセーフはIE7で使うようにしていました。hotfixがうまく機能しなくても

IE7が使えれば良いと思って適用してみましたが、考えが甘かったようです.....。

WMwareの仮想マシン上でWindowsを動かしていれば、こんな時にスナップショットから直ぐに環境を戻せた

のですが、残念ながら仮想マシンではLinuxしか動かしていません。

アドオンとしてToolbar5.5が話題になっていますが、当方環境ではSafety Minder2.1.0.52もあります。

Firefox4.0.1になったタイミングでSafety Minderは無効化されていますが、Firefox4.0対応で復活するのでしょうか。

復活してくれないと非常に困ります。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)


tsuhoshi さんは書きました:

アドオンとしてToolbar5.5が話題になっていますが、当方環境ではSafety Minder2.1.0.52もあります。

Firefox4.0.1になったタイミングでSafety Minderは無効化されていますが、Firefox4.0対応で復活するのでしょうか。

復活してくれないと非常に困ります。


それはまた別の話だと思いますよ。

NISや360とは別のソフトですので。

Windows 10 pro 64bit / Firefox / NIS v.22
拍手1 Stats

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)


pal さんは書きました:
それはまた別の話だと思いますよ。

NISや360とは別のソフトですので。


Safety MinderはNISや360に対するアドオンソフトですので、本体よりも対応が遅くなる可能性はあります。

ですが、対応内容はおそらく同じでしょうし、これだけ間があいたのですから一緒に対応して欲しいです。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

ご不便おかけし申し訳ありません。

jeimusuさんが投稿したとおり、本HotfixはFirefox 4.0に対応したもので、4.01には対応しておりません。

現在Firefox 4.0 (4.01などの今後のマイナーアップデート版を含む)に対応したパッチをNIS 2011とN360 v5に配布する準備をしております。パッチは近日中に配布される予定ですのでもうしばらくお待ちください。

株式会社シマンテックノートン コミュニティ 日本版コミュニティマネージャー 高島
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

先ほども投稿しましたが、Firefox 4.01対応のパッチを近日中にリリースする準備を進めております。

既にこちらで米国のフォーラムでの投稿が紹介されていますので、簡単な意訳をさせていただきます。

シマンテック社員  abhay_kulkarniの投稿

Firefoxの互換性についていくつか質問をいただきましたのでこちらにまとめて回答させて頂きます。

何故、Firefox新バージョンに対応するアップデートに時間がかかっているのか。

Firefoxもノートンもそれぞれ個別のリリーススケジュールで開発が進んでいます。

したがって我々がFirefoxのスケジュールに合わせるのはとても難しいことです。

Firefoxのベータ版でノートンが正しく動作するか定期的にテストを行っています。しかしMozillaはベータ開発後半になるにつれ、互換性を無視してしまう傾向があります。こういったことが過去何度かあったため、我々は保守的な対応にならざるを得ず、我々がテストを行ったFirefox のバージョンのみに、ノートン ツールバーを有効としています。ノートン ツールバーがブラウザをクラッシュさせるぐらいなら、機能自体を無効にする方が良いと考えています。

バージョンアップしても互換性が保たれているアドオンがあると疑問に思っている方もいるかと思います。Firefoxは2つのアドオンタイプがあり ます。JavaScriptで書かれているアドオンと、バイナリ形式のアドオンです。JavaScriptのアドオンは互換性が高いように見えます。しかし、 パフォーマンスとセキュリティの観点から、ノートンのアドオンはバイナリ形式で作られており、Mozillaによってそのインターフェースの互換性はリリース の間によく無視されることがあります。

我々はMozillaと協力し、ノートン ツールバーをタイムリーにリリースできるよう、プロセスの改善を行っています。彼らの最近の回答からも今後もっとスムーズに対応ができることと思います。


なぜノートン ツールバーのHotfixは Firefox4.01に非対応なのですか。


通常Mozillaはマイナーアップデート(例えば4.01と4.0)の際はインターフェースの互換性を無視すことはありません。その為、我々もマイナーリリースに対応するようにしています。しかし今回のHotfixは限られた時間・方法でテストされたため、Firefox4.0のみに限定して対応、としました。

侵入防止のアドオンは限られたインターフェースを利用し機能することができることと、データ重視なため、互換性レベルをベースにある程度の機能を無効にし、ユーザーインパクトがあまりない状態にできるため、Firefox4.0に対応できると確信し、これからリリースを行いました。

良いニュースは、我々はFirefox4.0(と、4.01、4.02などの今後のマイナーアップデート)に対応するノートン製品のパッチのリリースを進めています。このパッチは近日中にリリースされます。

Firefoxが、4.1や4.5などといったメジャーなアップデートをリリースする際は、彼らは互換性を保証していないので、我々はそれに合わせたノートン製品のアップデートをリリースしなければなりません。ユーザーがブラウザをアップデートした時に、ブラウザがクラッシュしたり、それ以上の深刻な問題が起きないようにする為です。

--- 意訳終わり ---

このように開発側で改善や対応を進めています。パッチについてももうすぐリリースされますので、もうしばらくお待ちください。

株式会社シマンテックノートン コミュニティ 日本版コミュニティマネージャー 高島
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

アメリカでは、18.6.0.29 のアップデートを一部のユーザをピックアップして配布したようですね。

それによる検証(情報収集)が終わり、昨日、英語版のアップデートがリリースされたようです。

Tim_Lopezさんの投稿

なんだかんだで使えないのはやっぱり不便ですので、期待して待ってます。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

お待たせしました!日本でもパッチの配布が開始されました。

詳しくはこちらをご覧ください。

【新しい更新 18.6.0.29】ノートン インターネット セキュリティ 2011 / ノートン アンチウイルス 2011

よろしくお願いします。

株式会社シマンテックノートン コミュニティ 日本版コミュニティマネージャー 高島
拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

liveupdateによってFirefox4.0.1でtoolbar 5.6が認識され、問題なく動作することを確認しました。

が、palさんの予測通りsafety minderの対応はまだでした。こちらの対応はいつ頃になるのでしょうか。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

18.6.0.29へアップデート後、Firefox 4.0.1 にて Norton Toolbar 5.6 が正常に動作していることを確認しました。

GJ!

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

早速のたいおう、ありがとうございます。 助かりました。

拍手0

Re: Firefox 4に対応するためのHotfixを公開しました(追記:5/11)

18.6.0.29適応後あたりから、ダウンロード後のファイルスキャン時に反応が重くなったように思うのですが。(Firefox使用)

Windows 10 pro 64bit / Firefox / NIS v.22