• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs

Not what you are looking for? Ask the experts!


error 2146959355 unable to take required system restore point

Under PC tuneup, i get attention needed as it says "windows registry could be cleaned by deleing broken entries". i fun fix all and get the message above. I have windows 7 home premuiium edition installed and norton 360 version 5.0 with patch installed. Need help. Thanks 


Kudos1 Stats

Re: error 2146959355 unable to take required system restore point


Registry cleanup carries some risks, so Norton protects you, when you'ree going to do that, by making a system restore point. That way, should registry cleanup produce any undesired effects, you can just run a system restore and get back to where you were.

What this is telling you is that there's some reason it's unable to perform this step. One common reason for this is lack of hard drive space: since a system restore point records all the information it would take to put you back to where you are in the event of a mishap, these can take quite a bit of space. Another possibility would be if you were trying to run this from an account without Administrator privileges. If either of those is the case, you may be able to fix the condition (by running a hard disk cleanup, in the former case, or logging in from an Administrator account in the latter, and then trying to run the registry cleanup.

EDIT: on searching for previous encounters of this problem, I was able to find the following, which offers a couple of solutions. The list of steps relating to "Windows Management Instrumentation" toward the top appears to have solved the problem for ssomeone before (albeit using an earlier version of the product); if that doesn't work for you, there is a link at the bottom to a procedure from the Knowledge Base that will allow you to proceed a different way that's just as safe.


Re: error 2146959355 unable to take required system restore point

Please try the solution from the following Symantec KB:


Let us know if this worked for you.




Re: error 2146959355 unable to take required system restore point


   Thanks for the help so far. I tried increasing space for system restore and was able to create a system restore point but still got the same error message. I looked up my access and I am the adminstrator so no problem there. I also turned off system restore, creadtd a backup copy of the registry and tried running registry cleanup again but, still same error.

   Any more suggestions greatly appreciated.

   Thanks again

   Albert Shelton III


Re: error 2146959355 unable to take required system restore point

Hi, Albert,

I had assumed, yesterday, that the link that HarryP helpfully posted was to the solution that I had boneheadedly never gotten around to coming back and adding to my post from the 24th. And I am reminded yet again why it's never a good thing to "assume!" 

Try the 10-step solution that yogesh_mohan first offers, which solves the problem for Harley55 here:


Note: HarryP's link is essentially the solution that Yogesh offered at the end of the same thread, to hpearce, for whom the first solution did not work. So it appears that each can solve this problem under different circumstances.

Let us know if the 10-step solution works any better for you in your. Sorry I've made two screwups that have perhaps cost you a whole week of this!


Re: error 2146959355 unable to take required system restore point


  Hi there. Thanks for the link to the 10 step process. I stopped the windows management instrumentation but, when i got to th step to delete the repository folder, i could not delete it as the file was being used somewhere else. So i looked inside the folder and there were 5 files. i tried deleting them individually, but each one said it was open in Apllication Experience. I found that program, stopped it and tried deleting the repository folder again. Now i got that the file was being used by Application Information. I tried stoping that program but that caused more problems and would not stop. So still need help.

  Any suggestions greatly appreciated.


  Albert Shelton III 

This thread is closed from further comment. Please visit the forum to start a new thread.