• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs

Not what you are looking for? Ask the experts!


Cannot add attachments to email

I have had NIS for Mac for years. When my subscription ran out last week, I decided to get Norton for free from my internet provider, Comcast, rather than pay for another year. I didn't change any settings.

Now, when I use my web-based Yahoo email, I can no longer attach anything to the email. This happens (or, rather, doesn't happen) in both Safari and Firefox. 

Since the only thing I've changed on the computer is getting Norton from Comcast rather than directly from Norton, I tend to think Norton is the problem. And, if Norton isn't the problem, I need to know that, too. Otherwise, when I try to email Yahoo, they will blow me off with a stock "it's not us" reply. As it is, I have a feeling as soon as Yahoo's computer sees "Norton" in my question, I'd get a robo-response.  

Because everything in  Norton is written in computer-ese, I do not understand what any of it means, so I can't tell if I am somehow blocking the attachments from getting attached.

My computer is an eMac, OS X10.4.11.

Thank you! 



Re: Cannot add attachments to email

Hi ReneeH,

I'm a Symantec employee and will help you determine whether or not your NIS install is in anyway causing your issue.

First, I'd like to ask some basic questions so we can better proceed.

1. What version of NIS are you using? This is best found at the Norton Firewall About Box. Launch NPF and from the menu bar select About Norton Firewall from the Norton Firewall menu. It'll say something along the lines of "Version 4.2.1 (7)."

2. Is Firewall enabled? Launch NPF and view the default Status tab. There "Firewall" will either indicate "Enabled" or "Disabled."

3. Do you have files or info protected by Norton Confidential? Launch Norton Confidential, select the Information Guard tab and view the Guarded Information field. Select File Guard tab and view the Guarded Files field. Are there any entries/files within either of these locations?

4. Are you able to send email messages without any attachments? I assume the answer is "yes," but please confirm.

Please provide answers for all of the above and I'll get back to you ASAP. In the mean time, if they're not already, try disabling Norton Confidential's Info Guard and File Guard features. Also, set Norton Firewall's Connection Blocking and Application Blocking features to Off. Then try to attach some file to your email/s.

Please remember to re-enable any features you may have disabled after conducting this test. I don't want you go without some protection that you come to depend on.

Again, let me know and we'll see what we can do.




Re: Cannot add attachments to email

You'd have to give us more information as to what happens you try to attach something in Yahoo. Does the "Attach" button do nothing?

It may be that Yahoo's Web site no longer supports the browser that your Mac is running, or at least, they no longer test with the browser that your Mac is running. Mac OS X 10.4.11 only supports Firefox 3, when the latest Firefox is Firefox 7. Same situation with Safari.

Try David's steps above to rule out our software, but if that doesn't help you may want to try a different Web browser if one is available.

Ryan McGann Technical Director Norton Business Unit, Symantec

Re: Cannot add attachments to email


Thanks for helping!  

1. It's version 4.2.1.(7).

2. Yes, Norton firewall is enabled.

3. No, I don't have any files listed as guarded in either Information Guard or File Guard.

4. Yes, I can send emails without attachments.

I disabled Information Guard and File Guard and turned off Connection Blocking and Application Blocking. I was then able to attach a file to an email. I turned Information and File Guards back on and could still attach a file to an email. Then I turned Connection and Application Blocking back on and was still able to attach a file to an email!

Could it really be as simple as turning things off and turning them back on again? That's technology I can understand!

Yes, the attach button did absolutely nothing. That was on Safari (4.1.3). With Firefox (3.6.23), there was a little wheel that spun and spun. And spun. I was able to attach files using this version of Safari literally an hour before I downloaded the Norton software from Comcast, so I doubt Yahoo no longer supports it.

I do realize I have a problem with only being able to update software to a certain point because my computer is pre-intel Mac. But what can a person do who can't afford a new computer but hobble along? And profusely thank the kind people who help me muddle through! Thank you both very much for your help and patience. I really, really appreciate it!


Re: Cannot add attachments to email

Hi ReneeH,

well, at this point I cannot say for sure what the issue was. However, if the issue is no more I say we leave well enough alone.

I am curious about a couple of things..

1. What was duration of time that you experienced "the problem?"

2. Over that period of time, had you ever shutdown or restarted your system? Some folks shutdown or restart their system only when absolutely necessary.

These answers could help if we/you encouter this issue again.




Re: Cannot add attachments to email

I experienced the problem for 2 to 3 days - from the time I downloaded NIS for Mac from Comcast to the time I figured out where to go for help, and you answered.

I restart the computer whenever I download a Norton update, any other software update. I repair permissions after I do updates. Periodically, I clear Safari's cookies, empty the cache, and reset Safari. If there's more I need to do or know, please, let me know.

Maybe I'll find out for sure if the problem is solved after I do my first Norton update since getting Norton from Comcast. If attachments still attach, then the fix fixed it!

This thread is closed from further comment. Please visit the forum to start a new thread.