• All Community
    • All Community
    • Forums
    • Ideas
    • Blogs

Not what you are looking for? Ask the experts!


Framework and ccsvchst.exe problem fixed

I've been having a problem with NIS 2011 hogging system resources, slowing program launches, slowing email downloads, and generally being unresponsive to mouse clicks. My Dell desktop PC is a fast one (i7-2600, 3.40 GHz, 64-bit OS), but recently was anything but. I noticed the hard drive light was on almost constantly. Using Windows 7's Task Manager I checked out the processes and found ccsvchst.exe was constantly writing to the hard drive, although CPU use seemed okay. I tried accessing NIS, but even that was very slow to respond, if at all. Eventually I got an error message saying there was a problem with Framework, leading me here and a possible fix: delete NIS and run Norton Removal Tool.

I tried to delete NIS through the Control Panel, but the Norton removal wizard would only go so far before stalling out; I went and had dinner and when I came back it was still "in process." I rebooted and tried removing it immediately upon startup. Same problem; the removal stalled. I did this twice with the same result. Then I rebooted and immediately accessed NIS, shutting down each of the switches, one by one. It was a slow process; the hard drive was in constant use. I disconnected from the internet and rebooted, immediately heading for Control Panel and program removal. This time, it worked, very quickly.

Then I ran Norton Removal Tool. It didn't work. It told me I had Norton Utilities 14 still on my PC. Interestingly, I had properly removed it via Control Panel. So I reloaded it, then removed it again. The removal tool said it was still there and wouldn't let me go any further.

So I gave up on that and simply installed NIS 2012 (which I had downloaded to my desktop as instructed here).

That did the trick. Today my PC is quiet and fast, programs are loading normally, and mouse clicks produce immediate response. I'll be reinstalling Norton Utilities shortly.



Re: Framework and ccsvchst.exe problem fixed

Glad that fixed your problems, but I've got the same problems and it's a new (tone month old) install of NIS 2012.  Starting about two weeks ago, ccSvcHst.exe intermittently hangs on system shutdown, and I occasionally get an error box telling me that ccSvcHst tried to read an invalid memory address.  I get the Framework error on a reboot after the memory address error.  In all cases, running the Norton support scan shows no problems, and a second reboot seems to make the problems go away for a while at least.

NIS seemed to run as expected for after the initial install and the first reinstall, and then I started having problems.  Update related perhaps?  Nathan suggests another uninstall/reinstall (of course), and I've already done that once when the systray icon showed a red x instead of a checkmark although everything seemed to be working (and a chat session was unable to resolve that one).   I don't think I should have to reinstall the package every couple weeks though, and I'd like to see a stable and working product.     XP, SP3

This thread is closed from further comment. Please visit the forum to start a new thread.